Subject: Guidance on avoiding session pinning with psqlODBC and RDS Proxy

From: Neeta Ghadge <[email-masked]>
Date: Sun, 16 Nov 2025 14:53:02 +0000

Hi,
We are currently using PostgreSQL 16.5 with the ODBC driver (psqlodbcw.so version 17.00.0006) in an environment that relies on Amazon RDS Proxy.
We have observed that the driver automatically issues the following SQL statements at connection startup:
SET DateStyle = 'ISO';
SET extra_float_digits = 2;
SHOW transaction_isolation;

While harmless in most cases, these queries cause AWS RDS Proxy to pin sessions, which reduces pooling efficiency. We can neutralize the SET commands using RDS Proxy's InitQuery feature, but SHOW transaction_isolation still forces pinning.

Could you please suggest recommended ways to handle this scenario when using psqlODBC with RDS Proxy? Specifically, are there configuration options or best practices to avoid or minimize session pinning while still maintaining ODBC compliance?

Thank you for your guidance.

Thanks and Regards,
Neeta Ghadge

This message and the information contained herein is proprietary and confidential and subject to the Amdocs policy statement, you may review at https://www.amdocs.com/about/email-disclaimer <https://www.amdocs.com/about/email-disclaimer>

Amdocs Development Centre India Private Limited having CIN: U72200PN2004PTC0188320 converted into Amdocs Development Centre India LLP (A limited liability partnership with LLP Identification Number: AAI-6901 effective 28th Feb 2017)

---

From: Dave Cramer <[email-masked]>
Date: Mon, 17 Nov 2025 11:21:45 -0500

Hi Neeta,

I'm curious why RDSProxy is pinning on this. I can't think of any reason to
pin on a SHOW
That said, I'm equally curious why psqlODBC is doing it, it doesn't really
need to know the transaction isolation level

Dave Cramer
www.postgres.rocks

On Mon, 17 Nov 2025 at 05:19, Neeta Ghadge <[email-masked]> wrote:

> Hi,
> We are currently using PostgreSQL 16.5 with the ODBC driver (psqlodbcw.so
> version 17.00.0006) in an environment that relies on Amazon RDS Proxy.
>
> *SET DateStyle = 'ISO';*
> *SET extra_float_digits = 2;*
>
> *SHOW transaction_isolation;*
>
>
>
> While harmless in most cases*, these queries cause AWS RDS Proxy to pin
> sessions, which reduces pooling efficiency.* We can neutralize the SET
> commands using RDS Proxy’s InitQuery feature, but SHOW
> transaction_isolation still forces pinning.
>
>
>
> Could you please suggest recommended ways to handle this scenario when
> using psqlODBC with RDS Proxy? Specifically, are there configuration
> options or best practices to avoid or minimize session pinning while still
> maintaining ODBC compliance?
>
>
>
> *Thanks and Regards,*
> *Neeta Ghadge*
> This message and the information contained herein is proprietary and
> confidential and subject to the Amdocs policy statement, you may review at
> https://www.amdocs.com/about/email-disclaimer
>
> Amdocs Development Centre India Private Limited having CIN:
> U72200PN2004PTC0188320 converted into Amdocs Development Centre India LLP
> (A limited liability partnership with LLP Identification Number:
> AAI-6901 effective 28th Feb 2017)
>

---

From: Dave Cramer <[email-masked]>
Date: Mon, 17 Nov 2025 11:44:15 -0500

Hi,

Neeta,

Talking to some folks at Amazon, they don't think it should pin. Can you
open a ticket with them?

Dave Cramer
www.postgres.rocks

On Mon, 17 Nov 2025 at 11:21, Dave Cramer <[email-masked]> wrote:

> Hi Neeta,
>
> I'm curious why RDSProxy is pinning on this. I can't think of any reason
> to pin on a SHOW

---

From: Neeta Ghadge <[email-masked]>
Date: Mon, 17 Nov 2025 16:52:39 +0000

Hi,
Thank you for your prompt response.
It's not SHOW command, rather it is SET that is causing session pinning. I will try to find alternate approaches to avoid session pinning.

Thanks and Regards,
Neeta Ghadge

From: Dave Cramer <[email-masked]>
Sent: Monday, November 17, 2025 10:14 PM
To: Neeta Ghadge <[email-masked]>
Cc: [email-masked]
Subject: Re: Guidance on avoiding session pinning with psqlODBC and RDS Proxy

You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification>
CAUTION: This email is from an external source. Please don't open any unknown links or attachments.
Hi,

Neeta,

Talking to some folks at Amazon, they don't think it should pin. Can you open a ticket with them?

Dave Cramer
www.postgres.rocks<http://www.postgres.rocks>

On Mon, 17 Nov 2025 at 11:21, Dave Cramer <[email-masked]<mailto:[email-masked]>> wrote:
Hi Neeta,

I'm curious why RDSProxy is pinning on this. I can't think of any reason to pin on a SHOW
That said, I'm equally curious why psqlODBC is doing it, it doesn't really need to know the transaction isolation level

Dave Cramer
www.postgres.rocks<http://www.postgres.rocks>

On Mon, 17 Nov 2025 at 05:19, Neeta Ghadge <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks and Regards,
Neeta Ghadge

This message and the information contained herein is proprietary and confidential and subject to the Amdocs policy statement, you may review at https://www.amdocs.com/about/email-disclaimer
Amdocs Development Centre India Private Limited having CIN: U72200PN2004PTC0188320 converted into Amdocs Development Centre India LLP (A limited liability partnership with LLP Identification Number: AAI-6901 effective 28th Feb 2017)
This message and the information contained herein is proprietary and confidential and subject to the Amdocs policy statement, you may review at https://www.amdocs.com/about/email-disclaimer <https://www.amdocs.com/about/email-disclaimer>

---

From: Dave Cramer <[email-masked]>
Date: Mon, 17 Nov 2025 12:01:33 -0500

Ah,

OK, I will have to change the driver. I think that is doable.

Can you create an issue here
https://github.com/postgresql-interfaces/psqlodbc

Dave Cramer
www.postgres.rocks

On Mon, 17 Nov 2025 at 11:52, Neeta Ghadge <[email-masked]> wrote:

> It’s not SHOW command, rather it is *SET* that is causing session
> pinning. I will try to find alternate approaches to avoid session pinning.
>
>
>
>
>
> *Thanks and Regards,*
>
> *Neeta Ghadge*
>
>
>
> *From:* Dave Cramer <[email-masked]>
> *Sent:* Monday, November 17, 2025 10:14 PM
> *To:* Neeta Ghadge <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: Guidance on avoiding session pinning with psqlODBC and RDS
> Proxy
>
>
>
> You don't often get email from [email-masked]. Learn why this
> is important <https://aka.ms/LearnAboutSenderIdentification>
>
> *CAUTION:* This email is from an external source. Please don’t open any
> unknown links or attachments.
>
> Hi,
>
>
>
> Neeta,
>
>
>

---

From: Neeta Ghadge <[email-masked]>
Date: Mon, 17 Nov 2025 17:12:30 +0000

Thank you 😊
I have created a new issue : https://github.com/postgresql-interfaces/psqlodbc/issues/143

Thanks and Regards,
Neeta Ghadge

Sent: Monday, November 17, 2025 10:32 PM

You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification>
CAUTION: This email is from an external source. Please don’t open any unknown links or attachments.
Ah,

Can you create an issue here https://github.com/postgresql-interfaces/psqlodbc

Dave Cramer
www.postgres.rocks<http://www.postgres.rocks/>

On Mon, 17 Nov 2025 at 11:52, Neeta Ghadge <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
Thank you for your prompt response.
It’s not SHOW command, rather it is SET that is causing session pinning. I will try to find alternate approaches to avoid session pinning.

Thanks and Regards,
Neeta Ghadge

From: Dave Cramer <[email-masked]<mailto:[email-masked]>>
Sent: Monday, November 17, 2025 10:14 PM
To: Neeta Ghadge <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: Guidance on avoiding session pinning with psqlODBC and RDS Proxy

You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification>
CAUTION: This email is from an external source. Please don’t open any unknown links or attachments.
Hi,

Neeta,

Dave Cramer
www.postgres.rocks<http://www.postgres.rocks/>

Dave Cramer
www.postgres.rocks<http://www.postgres.rocks/>

While harmless in most cases, these queries cause AWS RDS Proxy to pin sessions, which reduces pooling efficiency. We can neutralize the SET commands using RDS Proxy’s InitQuery feature, but SHOW transaction_isolation still forces pinning.

Thanks and Regards,
Neeta Ghadge

---

From: Jon Raiford <[email-masked]>
Date: Mon, 17 Nov 2025 17:23:38 +0000

Here is the RDS documentation for this:

https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/rds-proxy-pinning.html

There was mention by OP of using InitQuery, but my understanding is that as long as the driver makes the set call that the pinning will happen regardless of what state the connection is currently in. My research also showed that the show command should not have affected the pinning.

Jon

From: Dave Cramer <[email-masked]>
Date: Monday, November 17, 2025 at 12:13 PM
To: Neeta Ghadge <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: Guidance on avoiding session pinning with psqlODBC and RDS Proxy

Ah,

Can you create an issue here https://github.com/postgresql-interfaces/psqlodbc<https://github.com/postgresql-interfaces/psqlodbc>

Dave Cramer

Thanks and Regards,
Neeta Ghadge

Neeta,

Dave Cramer

Dave Cramer

Thanks and Regards,
Neeta Ghadge

This message and the information contained herein is proprietary and confidential and subject to the Amdocs policy statement, you may review at https://www.amdocs.com/about/email-disclaimer<https://www.amdocs.com/about/email-disclaimer>
Amdocs Development Centre India Private Limited having CIN: U72200PN2004PTC0188320 converted into Amdocs Development Centre India LLP (A limited liability partnership with LLP Identification Number: AAI-6901 effective 28th Feb 2017)
This message and the information contained herein is proprietary and confidential and subject to the Amdocs policy statement, you may review at https://www.amdocs.com/about/email-disclaimer<https://www.amdocs.com/about/email-disclaimer>
Amdocs Development Centre India Private Limited having CIN: U72200PN2004PTC0188320 converted into Amdocs Development Centre India LLP (A limited liability partnership with LLP Identification Number: AAI-6901 effective 28th Feb 2017)

---

From: Dave Cramer <[email-masked]>
Date: Mon, 17 Nov 2025 15:41:53 -0500

Yes, I know how to fix it. Working on it.
Dave Cramer
www.postgres.rocks

On Mon, 17 Nov 2025 at 12:23, Jon Raiford <[email-masked]> wrote:

> There was mention by OP of using InitQuery, but my understanding is that
> as long as the driver makes the set call that the pinning will happen
> regardless of what state the connection is currently in. My research also
> showed that the show command should not have affected the pinning.
>
> Jon
>
>
> *From: *Dave Cramer <[email-masked]>
> *Date: *Monday, November 17, 2025 at 12:13 PM
> *To: *Neeta Ghadge <[email-masked]>
> *Cc: [email-masked] <[email-masked]>
> *Subject: *Re: Guidance on avoiding session pinning with psqlODBC and RDS
> Proxy
>
> Ah,
>