Subject: RE: pg*.dll and *.pdb files in psqlODBC have no version numbers

From: Mark Hill <[email-masked]>
Date: Wed, 25 Oct 2023 17:52:50 +0000

I posted these questions to this group a few weeks ago but haven't received a response so reposting to
see if anybody has any ideas.

We download the ODBC source from http://ftp.postgresql.org<http://ftp.postgresql.org/><http://ftp.postgresql.org/> and build it on-site, 13.02.0000 in this case.

A colleague noticed that the following files in the psqlODBC MSI for Windows have no version numbers:
pgenlist.dll
pgenlista.dll
pgxalib.dll
pgenlist.pdb
pgenlista.pdb
psqlodbc30a.pdb
psqlodbc35w.pdb

Does anyone know if that is be design or some other reason? Should they have version numbers?

I checked earlier build and the same holds for ODBC 12.02.0000.

Thanks, Mark

---

From: Dave Cramer <[email-masked]>
Date: Thu, 26 Oct 2023 05:51:22 -0400

On Wed, 25 Oct 2023 at 13:53, Mark Hill <[email-masked]> wrote:

> I posted these questions to this group a few weeks ago but haven’t
> received a response so reposting to
> We download the ODBC source from *http://ftp.postgresql.org*
> <http://ftp.postgresql.org/><*http://ftp.postgresql.org/*
> <http://ftp.postgresql.org/>> and build it on-site, 13.02.0000 in this
> case.
>
>

Doesn't look like we have ever versioned them. My guess is that by not
versioning them when you install the latest it overwrites the existing

Dave

---

From: "Wal, Jan Tjalling van der" <[email-masked]>
Date: Thu, 26 Oct 2023 11:52:11 +0000

Hello Dave,

I cannot check for v13.02.00 anymore, but by the looks of it v15.00.00 has the same.
Name
Extension
Size
Attributes
Modified
Version
libcrypto-3-x64.dll
dll
4,467,200
---A--------
20/06/2023 12:30
3.0.9.0
libpq.dll
dll
308,736
---A--------
20/06/2023 12:58
15.0.3.23170
libssl-3-x64.dll
dll
774,144
---A--------
20/06/2023 12:30
3.0.9.0
msvcp140.dll
dll
627,992
---A--------
22/12/2021 23:34
14.16.27033.0
pgenlist.dll
dll
29,696
---A--------
23/06/2023 16:23
<unknown>
pgenlist.pdb
pdb
634,880
---A--------
23/06/2023 16:23
pgenlista.dll
dll
29,696
---A--------
23/06/2023 16:23
<unknown>
pgenlista.pdb
pdb
634,880
---A--------
23/06/2023 16:23
pgxalib.dll
dll
35,328
---A--------
23/06/2023 16:23
<unknown>
psqlodbc30a.dll
dll
572,416
---A--------
23/06/2023 16:23
15.0.0.0
psqlodbc30a.pdb
pdb
1,904,640
---A--------
23/06/2023 16:23
psqlodbc35w.dll
dll
586,752
---A--------
23/06/2023 16:23
15.0.0.0
psqlodbc35w.pdb
pdb
1,945,600
---A--------
23/06/2023 16:23
vcruntime140.dll
dll
85,784
---A--------
22/12/2021 23:34
14.16.27033.0

That can confirm that both older and newer versions consistently have no version for some files.
Which seems to be in line with the previous answer.
All files shown here are in a subdir \psqlODBC\1500\bin.
In a still existing .\1302\bin only two files remain: libcrypto-1_1-x64.dll and libssl-1_1-x64.dll.
So overwriting may not be what happens, but old version are removed/uninstalled and new dll are written along with the newer/matching driver installation.

I hope this adds something useful for you.

Kind regards,           Jan Tjalling van der Wal
 Wageningen Marine Reseach (WMR)  / formerly IMARES Institute for Marine Resources & Ecosystem Studies
Ankerpark 27, 1781 AG Den Helder       Postbus 57, 1780 AB Den Helder
Tel. +31 (0)317-4 87147 #                     GSM. +31 (0)626120915 (privé) #
# Ma+Di Vr 09:00-18:00, Wo XX, Do+Vr 09:00-18:00
[email-masked]<mailto:[email-masked]>
From: Dave Cramer <[email-masked]>
Sent: Thursday, October 26, 2023 11:51 AM
To: Mark Hill <[email-masked]>
Cc: [email-masked]
Subject: Re: pg*.dll and *.pdb files in psqlODBC have no version numbers

On Wed, 25 Oct 2023 at 13:53, Mark Hill <[email-masked]<mailto:[email-masked]>> wrote:

Doesn't look like we have ever versioned them. My guess is that by not versioning them when you install the latest it overwrites the existing

Dave

Thanks, Mark