Subject: ODBC Password Encryption - PostgreSQL ANSI(x64)

From: Joseph Fisher <[email-masked]>
Date: Fri, 7 Mar 2025 10:32:06 -0500

In Windows, please confirm that when using special characters within a
password string, the password stored is "mangled" when saving the string
under the ODBC.INI datasource in the registry.

[HKEY_CURRENT_USER\Software\ODBC\ODBC.INI\

So to use a password in a .net app with an OdbcConnection, don't use the
plain text password, instead use the ODBC.INI datasource saved mangled
password.

Thank you,
Joe

---

From: Dave Cramer <[email-masked]>
Date: Mon, 10 Mar 2025 09:09:33 -0400

Please post this to github https://github.com/postgresql-interfaces/psqlodbc
Dave Cramer
www.postgres.rocks