Subject: ODBC log4j

From: "Woods, Christopher (Customer Propositions & Delivery)" <[email-masked]>
Date: Tue, 8 Nov 2022 16:36:58 +0000

Hi,

I am new to PostgreSQL.  Are you able to advise if the ODBC driver is Log4j vulnerability free please?  I need to ensure before I can consider using it and could not see reference to it on the website / older posts in this group.

Thanks

Chris

 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++       

The opinions expressed in this email represent those of the individual and not necessarily those of Lombard North Central plc. The contents of this email may be privileged and are confidential. It may not be disclosed to or used by anyone other than the addressee(s), nor copied in any way. If received in error, please advise the sender, then delete from your system.

Lombard North Central plc does not accept responsibility for changes made to this message after it was sent. Should you wish to use email as a mode of communication, Lombard North Central plc is unable to guarantee the security of email content outside our own computer systems.

Please do not e-mail any account or other confidential information. Lombard North Central plc may monitor e-mails for business and operational purposes. By replying to this message you give your consent to our monitoring of your email communications with us.

While all reasonable care has been taken to avoid the transmission of viruses, it is the responsibility of the recipient to ensure that the onward transmission, opening or use of this message and any attachments will not adversely affect its systems or data. No responsibility is accepted by Lombard North Central plc in this regard and the recipient should carry out such virus and other checks as it considers appropriate.

Lombard North Central plc, Registered in England. No 337004. 

Registered Office: 250 Bishopsgate, London, EC2M 4AA. 

Authorised and regulated by the Financial Conduct Authority for consumer credit activities.

A member of NatWest Group.

Calls may be recorded.

 +++++++++++++++++++++++++++++++++++++++++++++++++++++++

---

From: Dave Cramer <[email-masked]>
Date: Tue, 8 Nov 2022 11:46:10 -0500

On Tue, 8 Nov 2022 at 11:39, Dave Cramer <[email-masked]> wrote:

> Hello Christopher,
>
> The ODBC driver is not written in JAVA, so it does not use log4j. I think
> it's safe to say that there are no log4j vulnerabilities in the ODBC driver.
>
> Regards,
> Dave Cramer
>
>
> On Tue, 8 Nov 2022 at 11:37, Woods, Christopher (Customer Propositions &
> Delivery) <[email-masked]> wrote:
>
>>
>>
>> Hi,
>>
>>
>>
>> I am new to PostgreSQL.  Are you able to advise if the ODBC driver is
>> Log4j vulnerability free please?  I need to ensure before I can consider
>> using it and could not see reference to it on the website / older posts in
>> this group.
>>
>>
>>
>> Thanks
>>
>>
>>
>> Chris
>>
>>
>>
>> The opinions expressed in this email represent those of the individual
>> and not necessarily those of Lombard North Central plc. The contents of
>> this email may be privileged and are confidential. It may not be disclosed
>> to or used by anyone other than the addressee(s), nor copied in any way. If
>> received in error, please advise the sender, then delete from your system.
>> Lombard North Central plc does not accept responsibility for changes made
>> to this message after it was sent. Should you wish to use email as a mode
>> of communication, Lombard North Central plc is unable to guarantee the
>> security of email content outside our own computer systems.
>> Please do not e-mail any account or other confidential information.
>> Lombard North Central plc may monitor e-mails for business and operational
>> purposes. By replying to this message you give your consent to our
>> monitoring of your email communications with us.
>> While all reasonable care has been taken to avoid the transmission of
>> viruses, it is the responsibility of the recipient to ensure that the
>> onward transmission, opening or use of this message and any attachments
>> will not adversely affect its systems or data. No responsibility is
>> accepted by Lombard North Central plc in this regard and the recipient
>> should carry out such virus and other checks as it considers appropriate.