Subject: Excel ODBC query loosing parameter when returning the query result directly to a pivot table.

From: Andreas Beier <[email-masked]>
Date: Wed, 8 Sep 2021 14:34:28 +0200

Hi everyone,

I am using postgres odbc for quite a while within within excel using
parameters (i.e. using ?s within the query).

When defining odbc queries in Excel I select "PivotTable Report" instead of
"Table", thus creating a pivot table directly without having the raw data
in an extra sheet.

Once created, I can alter the query and define parameter (s)linking to an
excel cell.

Everything works well until I (save and) reopen the file and try to update:
Than my excel crashs. :(

I did find out, that the parameter definition I defined before is empty
when opening the file. When I do redefine it, everthing works well again
until I (save and) reopen the file and try to update: Than my excel crashs.
:(

So it's very reproduceable.

I am using the 32bit driver, latest version and I am running Excel 2010 and
2016.

Any idea whats wrong here?

Thanks
Andreas

---

From: Danny Severns <[email-masked]>
Date: Wed, 8 Sep 2021 10:42:24 -0500

Have you tried looking at the Excel.dmp file that should have been 
created by the crash. You might also want to look at the windows event 
log to see if it is any help.  It sounds like a data type mismatch, but 
that is just a guess.

"It's so simple to be wise. Just think of something stupid to say and 
then don't say it." -Sam Levenson
On 9/8/2021 7:34 AM, Andreas Beier wrote:
> When defining odbc queries in Excel I select "PivotTable Report" 
> instead of "Table", thus creating a pivot table directly without 
> having the raw data in an extra sheet.
>
> Once created, I can alter the query and define parameter (s)linking to 
> an excel cell.
>
> Everything works well until I (save and) reopen the file and try to 
> update: Than my excel crashs. :(
>
> I did find out, that the parameter definition I defined before is 
> empty when opening the file. When I do redefine it, everthing works 
> well again until I (save and) reopen the file and try to update: Than 
> my excel crashs. :(
>
> I am using the 32bit driver, latest version and I am running Excel 
> 2010 and 2016.
>

---

From: Andreas Beier <[email-masked]>
Date: Thu, 9 Sep 2021 10:46:17 +0200

Thank you.

It is in fact a very long and well known excel problem, not specificly
connected to postgres-odbc. See:

https://stackoverflow.com/questions/44672251/excel-sql-data-query-into-pivot-table-fails-when-parameter-stored
https://superuser.com/questions/456242/excel-pivot-table-with-external-data-source-parameter-is-not-saved-with-workbook
https://social.technet.microsoft.com/Forums/Lync/en-US/e983efc2-ba95-4bdd-85bc-f5ce2647cbb4/cell-reference-parameters-in-connection-properties-of-excel-are-not-saved-how-do-i-fix-this?forum=excel
https://answers.microsoft.com/en-us/msoffice/forum/all/query-parameters-cell-reference-not-saved/85a83bbc-545c-4572-b39b-f296b3415efb
...

Thx for your help anyway!

Andreas

Am Mi., 8. Sept. 2021 um 17:42 Uhr schrieb Danny Severns <[email-masked]
>:

> Have you tried looking at the Excel.dmp file that should have been created
> by the crash.  You might also want to look at the windows event log to see
> if it is any help.  It sounds like a data type mismatch, but that is just a
> guess.
> "It's so simple to be wise. Just think of something stupid to say and then
> don't say it." -Sam Levenson
> When defining odbc queries in Excel I select "PivotTable Report" instead
> of "Table", thus creating a pivot table directly without having the raw
> data in an extra sheet.
>
> I am using the 32bit driver, latest version and I am running Excel 2010
> and 2016.
>