Subject: Need some informations about ODBC version and engine version

From: Daniel Moreau - HITECHPROS <[email-masked]>
Date: Wed, 12 Jan 2022 13:26:58 +0000

Hi ,

I’m Daniel Moreau (DBA at FDJ French customer gaming)

I must feed some information’s about ODBC version compatibility with PostGreSql engine version

Not easy to find a matrix compatibility 😊

I did check on PostGreSql site and I’ve seen some mails about this subject

I did read latest ODBC version should be compatible with all supported PostGreSql version

Does it true ?

Our PostGreSql versions are :   PostgreSQL - 10.5.12    and     PostgreSQL - 11.0.5

Addition to that I’ll need to know where to find ODBC soft to download

Regards,

Daniel

DBA Teradata (DataHub)

Our ethic : never blame, just understand , help and support

---

From: Guillaume Lelarge <[email-masked]>
Date: Wed, 12 Jan 2022 16:50:20 +0100

Hi,

> I did read latest ODBC version should be compatible with all supported

It is true.

Our PostGreSql versions are :   PostgreSQL - 10.5.12    and     PostgreSQL
> - 11.0.5
10 and 11 are currently maintained, and the latest ODBC driver should work
with them.

> Addition to that I’ll need to know where to find ODBC soft to download

https://www.postgresql.org/ftp/odbc/versions/

Regards.

-- 
Guillaume.

---

From: Daniel Moreau - HITECHPROS <[email-masked]>
Date: Wed, 12 Jan 2022 17:32:25 +0000

Hi Guillaume,

Big thanks for your useful help

Regards,

Daniel

De : Guillaume Lelarge <[email-masked]>
Envoyé : mercredi 12 janvier 2022 16:50
À : Daniel Moreau - HITECHPROS <[email-masked]>
Cc : [email-masked]; [email-masked]
Objet : Re: Need some informations about ODBC version and engine version

ATTENTION: Cet e-mail provient d'une société tierce. Veuillez ne pas cliquer sur les liens ou ouvrir les pièces jointes à moins de connaître l'expéditeur et que le contenu soit sain.
En cas de doute cliquez sur le poisson ou transmettez le message à [email-masked]<mailto:[email-masked]>

Hi,

Le mer. 12 janv. 2022 à 16:32, Daniel Moreau - HITECHPROS <[email-masked]<mailto:[email-masked]>> a écrit :
Hi ,

Does it true ?

It is true.

10 and 11 are currently maintained, and the latest ODBC driver should work with them.

https://www.postgresql.org/ftp/odbc/versions/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.postgresql.org%2Fftp%2Fodbc%2Fversions%2F&data=04%7C01%7Cdmoreau.hitechpros%40lfdj.com%7C7b5602c75abf417fe94008d9d5e34479%7Cb1a7639e6f68471fa534787509510be4%7C0%7C0%7C637775996326504805%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=y2jpIkU%2B2qE2X0KsJMgdiJKGJrcoqAXRVGEMPPqltfg%3D&reserved=0>

Regards.

--
Guillaume.

---

From: Daniel Moreau - HITECHPROS <[email-masked]>
Date: Thu, 20 Jan 2022 14:52:58 +0000

Hello Guillaume,

Can you tell me the difference between the 3 packages for ODBC please ?

psqlodbc_11_01_0000
psqlodbc_11_01_0000-x64
psqlodbc_11_01_0000-x86

The first one is twice bigger than the two others

Does it means the first one includes odbc 32 bits and 64 bits  ?

Regards,

Daniel

Hi,

Does it true ?

It is true.

Regards.

--
Guillaume.

---

From: Guillaume Lelarge <[email-masked]>
Date: Thu, 20 Jan 2022 16:39:42 +0100

Hi,

> Does it means the first one includes odbc 32 bits and 64 bits  ?

I have no idea (apart from the obvious x64 and x86 files). If you
uncompress each, you'll see the first one is an exe, and the other two are
msi. Perhaps the exe has both msi. I don't know. Been a while since I've
used a Windows PC :-D

-- 
Guillaume.

---

From: Daniel Moreau - HITECHPROS <[email-masked]>
Date: Thu, 20 Jan 2022 16:03:04 +0000

Big thanks Guillaume

Envoyé : jeudi 20 janvier 2022 16:40

Hi,

Le jeu. 20 janv. 2022 à 15:53, Daniel Moreau - HITECHPROS <[email-masked]<mailto:[email-masked]>> a écrit :
Hello Guillaume,

psqlodbc_11_01_0000
psqlodbc_11_01_0000-x64
psqlodbc_11_01_0000-x86

I have no idea (apart from the obvious x64 and x86 files). If you uncompress each, you'll see the first one is an exe, and the other two are msi. Perhaps the exe has both msi. I don't know. Been a while since I've used a Windows PC :-D

--
Guillaume.