Subject: Named parameter binding support

From: Adrian Grucza <[email-masked]>
Date: Wed, 26 May 2021 15:29:24 +1000

Hi all,

I've attached a patch that adds support for named parameter binding when
calling procedures or functions. Applications can use SQLSetDescField to
specify parameter names, as described at
https://docs.microsoft.com/en-us/sql/odbc/reference/develop-app/binding-parameters-by-name-named-parameters

Notes:
* Works for input and output parameters
* Regression tests enhanced to include binding parameters by name

Regards,

Adrian Grucza  
Technical Lead
Tel: +61390185800
[email-masked]
www.iress.com
Level 16, 385 Bourke Street,
 Melbourne, Victoria, 3000
The contents of this email originated from Iress. For this purpose Iress includes Iress Limited and/or any of its subsidiaries, holding companies and trading entities. ​If you have received this email in error please notify the sender immediately and delete this email. 
nosig

---

From: "Inoue,Hiroshi" <[email-masked]>
Date: Fri, 28 May 2021 07:38:22 +0900

Hi Adrian,

I would take care of your patch.

Thanks.
Hiroshi Inoue

2021年5月26日(水) 14:29 Adrian Grucza <[email-masked]>:

>  <https://www.iress.com/>
> Adrian Grucza​
> [email-masked]* <[email-masked]>
> *www.iress.com* <https://www.iress.com/>
> Level 16, 385 Bourke Street,  Melbourne,  Victoria,  3000
> The contents of this email originated from Iress. For this purpose Iress
> includes Iress Limited and/or any of its subsidiaries, holding companies
> and trading entities. ​If you have received this email in error please
> notify the sender immediately and delete this email.
> nosig
>