Subject: Enabling connection pooling by default

From: Vadim Presniak - Consultant <[email-masked]>
Date: Fri, 20 Aug 2021 11:14:36 +0000

Hello,

We had been investigating why our application works dramatically slower with Postgre SQL DB than MS SQL Server and found that the main reason was related to the fact that CPTimeout option is not set for psqlOdbc driver, however this option is set by default to 60 for Microsoft ODBC drivers. We’ve done simple patch with changes for psqlOdbc driver installer to enable this option during driver installation. (0001-CPTimeout-option-set-to-60-for-odbc-driver-by-defaul.patch)  Is it possible to push this change in master branch?

This topic was discussed in 2008 (https://www.postgresql.org/message-id/F613CCFA0B7146A38D24394E8F29C66C%40andrusnotebook), but I could not find final decision for this topic.

Regards,
Vadim Presniak

________________________________

This email, including any attachments, may contain confidential and/or proprietary information intended only for the use of the recipient. If you are not the intended recipient, any distribution, copying, or use of this email or its attachments is prohibited. If you received this email in error, please reply to the sender immediately and delete this message and any copies.

Bentley Systems has taken all reasonable steps to ensure that this communication is free from viruses, data corruption, and unauthorized alteration. Bentley Systems does not accept liability for any damages that may be incurred as a result of this or any communication by email

[https://cdn2.webdamdb.com/310th_sm_UnR3pO7k0ir0.jpg?1616176329]

---

From: "Inoue,Hiroshi" <[email-masked]>
Date: Mon, 23 Aug 2021 11:50:35 +0900

Hi Vadim,

I would take care of this patch.

regards,
Hiroshi Inoue

2021年8月20日(金) 20:14 Vadim Presniak - Consultant <[email-masked]
>:

> Hello,
>
>
>
> We had been investigating why our application works dramatically slower
> with Postgre SQL DB than MS SQL Server and found that the main reason was
> related to the fact that CPTimeout option is not set for psqlOdbc driver,
> however this option is set by default to 60 for Microsoft ODBC drivers.
> We’ve done simple patch with changes for psqlOdbc driver installer to
> enable this option during driver installation.
> (0001-CPTimeout-option-set-to-60-for-odbc-driver-by-defaul.patch)  Is it
> possible to push this change in master branch?
>
>
>
> This topic was discussed in 2008 (
> https://www.postgresql.org/message-id/F613CCFA0B7146A38D24394E8F29C66C%40andrusnotebook),
> but I could not find final decision for this topic.
>
>
>
> Regards,
>
> Vadim Presniak
>
>
>
> ------------------------------
>
>
> This email, including any attachments, may contain confidential and/or
> proprietary information intended only for the use of the recipient. If you
> are not the intended recipient, any distribution, copying, or use of this
> email or its attachments is prohibited. If you received this email in
> error, please reply to the sender immediately and delete this message and
> any copies.
>
> *Bentley Systems has taken all reasonable steps to ensure that this
> communication is free from viruses, data corruption, and unauthorized
> alteration. Bentley Systems does not accept liability for any damages that
> may be incurred as a result of this or any communication by email*
>
>