Subject: ODBC error

From: "Victor K." <[email-masked]>
Date: Thu, 12 Oct 2023 13:23:01 +0300

Hello team
We have error when trying to get data from big table (about 7 GB) directly
to pivot table in MS Excel 2016 Pro Plus x64 over ODBC driver x64
Postrge on linux ver 15
ODBC psqlodbc_16_00_0000-x64
Error
OLE DB or ODBC error. An error occurred while processing table 'Query'. The
current operation was cancelled because another operation in the
transaction failed.
and
The commit or rollback request cannot be completed because there is no
active transaction in this session.
On small tables everything is okay

Victor
 //
  (,'')> why?
<(   )'
   | |
,,_ _,,

---

From: Dave Cramer <[email-masked]>
Date: Thu, 12 Oct 2023 09:42:33 -0400

On Thu, 12 Oct 2023 at 09:33, Victor K. <[email-masked]> wrote:

> OLE DB or ODBC error. An error occurred while processing table 'Query'.
> The current operation was cancelled because another operation in the
> transaction failed.
> and

I would suggest looking at the server logs.
Dave Cramer
www.postgres.rocks

---

From: "Victor K." <[email-masked]>
Date: Thu, 12 Oct 2023 17:14:36 +0300

On servers side logs
could not receive data from client connection timed out
 //
  (,'')> why?
<(   )'
   | |
,,_ _,,

чт, 12 окт. 2023 г. в 16:42, Dave Cramer <[email-masked]>:

>> We have error when trying to get data from big table (about 7 GB)
>> directly to pivot table in MS Excel 2016 Pro Plus x64 over ODBC driver x64
>> Postrge on linux ver 15

---

From: b55white <[email-masked]>
Date: Fri, 13 Oct 2023 10:14:35 -0500

>  
> On Oct 13, 2023 at 3:48 AM, Victor K.  <[email-masked]>  wrote:
>    
ODBC driver x64
 
Postrge on linux ver 15

Error
 
OLE DB or ODBC error. An error occurred while processing table 'Query'. The current operation was cancelled because another operation in the transaction failed.
 
and  
 
The commit or rollback request cannot be completed because there is no active transaction in this session.

 
 
Dave Cramer
 
www.postgres.rocks
 
> Client side logs would probably be useful.
>  
> Turm on through the DSN settings.  
>  
> Unless you specify a directory, they'll be in the users home dir.
>  
> Remember to shut them off when finished as they gobble space quickly.  
>  
>
>  
> Brad.  
>  
>  
>  
>