Subject: postgres 14 odbc 32 bit connection failure

From: Fernando <[email-masked]>
Date: Wed, 19 Jul 2023 09:24:42 -0300

Hi guys,
I am trying to connect a client running on windows 7 32 bits to a remote
server postgres 14 and i'm getting this error "....error system 126. Could
not found specific module.....psqlodbc35w.dll", I installed
psqlodbc_13_02_0000-x86-1, psqlodbc_15_00_0000-x86, psqlodbc_12_02_0000-x86
and always and always I am getting the same error message, any clues what
can be done?
Regards!
Fernando Aguada

---

From: Jon Raiford <[email-masked]>
Date: Wed, 19 Jul 2023 17:39:42 +0000

It sounds like you are missing some prerequisite DLL. Maybe you need the right MSVC redistributable installed? (https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170)

Another way to figure out what is missing for sure is to use a dependency walker like this one: https://github.com/lucasg/Dependencies. This is an open source version of the wonderful Dependency Walker from Microsoft with some added fixes.

Jon

From: Fernando <[email-masked]>
Date: Wednesday, July 19, 2023 at 9:37 AM
To: [email-masked] <[email-masked]>
Subject: postgres 14 odbc 32 bit connection failure
Hi guys,
I am trying to connect a client running on windows 7 32 bits to a remote server postgres 14 and i'm getting this error "....error system 126. Could not found specific module.....psqlodbc35w.dll", I installed psqlodbc_13_02_0000-x86-1, psqlodbc_15_00_0000-x86, psqlodbc_12_02_0000-x86 and always and always I am getting the same error message, any clues what can be done?
Regards!
Fernando Aguada

---

From: Fernando <[email-masked]>
Date: Wed, 19 Jul 2023 16:36:14 -0300

I install a newer MSVC redistributable, 2015 and works!,
many thanks!
Fernando

El mié, 19 jul 2023 a la(s) 14:39, Jon Raiford ([email-masked])
escribió:

> It sounds like you are missing some prerequisite DLL. Maybe you need the
> right MSVC redistributable installed? (
> https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170
> )
>
>
>
> Another way to figure out what is missing for sure is to use a dependency
> walker like this one: https://github.com/lucasg/Dependencies. This is an
> open source version of the wonderful Dependency Walker from Microsoft with
> some added fixes.
>
>
>
> Jon
>
>
>
> *From: *Fernando <[email-masked]>
> *Date: *Wednesday, July 19, 2023 at 9:37 AM
> *To: [email-masked] <[email-masked]>
> *Subject: *postgres 14 odbc 32 bit connection failure
>
> Hi guys,
>