Subject: Issue with the existing psqlodbc version of upgraded instance

From: Chirag Karkera <[email-masked]>
Date: Tue, 28 Nov 2023 13:49:29 +0530

Hi Team,

We have upgraded the RDS database version from v13.10 to v15.4

The current odbc version we are using is below,
Name        : postgresql-odbc
Version     : 09.03.0100
Release     : 2.el7
Architecture: x86_64

Do we have any specific matrix where we can check the compatibility issue.

As our application team is facing issue for one of the module.

Regards,
Chirag Karkera

---

From: Dave Cramer <[email-masked]>
Date: Tue, 28 Nov 2023 06:54:14 -0500

Hi Chirag,

> Do we have any specific matrix where we can check the compatibility issue.

09.03.0100 is almost 10 years old PostgreSQL: File Browser
<https://www.postgresql.org/ftp/odbc/versions/dll/>

While we don't have a compatibility matrix generally speaking you should be
using the latest version of the driver. My recommendation is that you
upgrade to at least 15.0 if not 16.0

Regards,
Dave Cramer

---

From: Chirag Karkera <[email-masked]>
Date: Tue, 28 Nov 2023 17:35:14 +0530

Hi Dave,

Thank You for your email.

Much appreciated !

Thank You and Take care !

Regards,
Chirag Karkera

On Tue, Nov 28, 2023 at 5:24 PM Dave Cramer <[email-masked]>
wrote:

> While we don't have a compatibility matrix generally speaking you should
> be using the latest version of the driver. My recommendation is that you