Subject: Hash Value for Updated POSTGRESQL?

From: "Moore, David A" <[email-masked]>
Date: Fri, 14 Feb 2025 19:33:27 +0000

Hello,

We are a NERC regulated organization in the critical infrastructure arena. The most recent zero-day injection bug (CVE-2025-1094) has us concerned. We are attempting to update our postgresql, which has several dependencies in our organization. We are failing to find a md5 to verify authenticity and perform an integrity check on the installation file. I have researched this and finding nothing on this topic except for other orgs finding the same issues. Can you please advise us on this and any method of verification that you may provide that will satisfy our stringent compliance requirements?

David A Moore
Senior Network Security Engineer
Gainesville Regional Utilities
OT System Control

[GRULogo]

This message and any attachments may contain confidential material and information and are intended only for the use of the intended recipient(s). If you are not the person to whom this message is addressed, be aware that any use, reproduction, or distribution of this message is strictly prohibited. If you received this in error, please contact the sender and immediately delete this email and any attachments.

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 18 Feb 2025 12:49:21 +0100

> On 14 Feb 2025, at 20:33, Moore, David A <[email-masked]> wrote:
> 
> Hello,  We are a NERC regulated organization in the critical infrastructure arena. The most recent zero-day injection bug (CVE-2025-1094) has us concerned. We are attempting to update our postgresql, which has several dependencies in our organization. We are failing to find a md5 to verify authenticity and perform an integrity check on the installation file. I have researched this and finding nothing on this topic except for other orgs finding the same issues. Can you please advise us on this and any method of verification that you may provide that will satisfy our stringent compliance requirements?

First of all, you are emailing the discussion list for the postgres ODBC driver
but reading your email I'm fairly sure you mean the postgres server and not the
ODBC driver.

Regarding package signatures, the postgres project only offers source core
downloads and for those hash fingerprints are available.  See for example the
17.3 version:

	https://www.postgresql.org/ftp/source/v17.3/

If you download a pre-built package or installer you need to check with whom it
is you are downloading from.

--
Daniel Gustafsson

---

From: "Moore, David A" <[email-masked]>
Date: Tue, 18 Feb 2025 13:07:24 +0000

Sorry about that

David A Moore

From: Daniel Gustafsson <[email-masked]>
Date: Tuesday, February 18, 2025 at 6:49 AM
To: Moore, David A <[email-masked]>
Cc: [email-masked] <[email-masked]>, LeMaster, James C <[email-masked]>, Gause Jr, George <[email-masked]>
Subject: [EXTERNAL] Re: Hash Value for Updated POSTGRESQL?

--
Daniel Gustafsson