Subject: Support for PostgreSQL stored procedure through ITX.

From: Prajakta Chinchole <[email-masked]>
Date: Fri, 9 Jul 2021 15:45:13 +0000

Hello Team,

This is Prajakta from HCL-ITX team.

We are trying to execute a PostgreSQL stored procedure through ITX. We are using ODBC driver that was provided with PostgreSQL. We observed that sqlExecDirect() failed for stored procedure with below error :
               DIAG [42809] ERROR: public.transfer(integer, integer) is a procedure;
Error while executing the query (1)

We have verified all parameters passed to sqlExecDirect(). All are as expected and earlier bind call was also succeeded. We have collected odbc traces generated for that run. Attached the same.

Could you please review the attached log and confirm why it was failing with ITX ?

Thanks,
Prajakta Chinchole.
Technical specialist - HCL.

::DISCLAIMER::
________________________________
The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. E-mail transmission is not guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or may contain viruses in transmission. The e mail and its contents (with or without referred errors) shall therefore not attach any liability on the originator or HCL or its affiliates. Views or opinions, if any, presented in this email are solely those of the author and may not necessarily reflect the views or opinions of HCL or its affiliates. Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of this message without the prior written consent of authorized representative of HCL is strictly prohibited. If you have received this email in error please delete it and notify the sender immediately. Before opening any email and/or attachments, please check them for viruses and other defects.
________________________________

---

From: Prajakta Chinchole <[email-masked]>
Date: Wed, 14 Jul 2021 10:57:01 +0000

Any update on below issue ?

Thanks,
Prajakta Chinchole.

From: Prajakta Chinchole
Sent: Friday, July 9, 2021 9:15 PM
To: [email-masked]
Subject: Support for PostgreSQL stored procedure through ITX.

Hello Team,

Thanks,
Prajakta Chinchole.

::DISCLAIMER::