Subject: PostgreSQLとpsqlodbcドライバーの互換性について

From: "[email-masked]" <[email-masked]>
Date: Mon, 15 Feb 2021 01:51:41 +0000

PostgreSQLとpsqlodbcドライバーの互換性についてお聞きしたいです。

PostgreSQL10.11に互換性のあるpsqlODBCドライバーをご教授願いたいです。
また、そのドライバーのOSのシステム要件を教えていただきたいです。
Windows server 2008 R2は許容されていますでしょうか。
想定としてはpsqlODBCドライバー10.3の想定です。

環境
PostgreSQL：10.11
OS環境：Windows server 2008 R2

よろしくお願いいたします。

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 16 Feb 2021 03:15:29 +0000

上記subjectの回答期限はわかりますか？？

なるべく早めにご回答いただけたら幸いです。

Outlook for iOS<https://aka.ms/o0ukef> を入手
________________________________
差出人: 市川　旺輝
送信日時: Monday, February 15, 2021 10:51:41 AM
宛先: [email-masked] <[email-masked]>
件名: PostgreSQLとpsqlodbcドライバーの互換性について

環境

PostgreSQL：10.11

よろしくお願いいたします。

---

From: Michael Paquier <[email-masked]>
Date: Wed, 17 Feb 2021 15:18:02 +0900

石川さま

> なるべく早めにご回答いただけたら幸いです。

本メーリングリストは英語でやりとりしますので、日本語を理解できる方が
少ないと思います。 

ポスグレ10.11が古いので、10.16への更新をおすすめいたします。

> 想定としてはpsqlODBCドライバー10.3の想定です。

10.03.0000ではないでしょうか？  Win 2008R2に使うのは問題ないと思います。
未サポートの古いOSなので、おすすめしませんが。

よろしくお願いいたします。
--
Michael

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 17 Feb 2021 06:51:58 +0000

Thanks Michael

I want to know the OS that meets the operating requirements of 10.03.0000

Where is the 10.03.0000 documentation that describes the operating requirements 

Thank you.

-----Original Message-----
From: Michael Paquier <[email-masked]> 
Sent: Wednesday, February 17, 2021 3:18 PM
To: 市川　旺輝 <[email-masked]>
Cc: [email-masked]
Subject: Re: PostgreSQLとpsqlodbcドライバーの互換性について

石川さま

よろしくお願いいたします。
--
Michael

---

From: Michael Paquier <[email-masked]>
Date: Thu, 18 Feb 2021 13:42:42 +0900

> Where is the 10.03.0000 documentation that describes the operating requirements

The existing docs are outdated, still offer some information:
https://odbc.postgresql.org/faq.html
"This includes Windows 95, 98, ME, NT, 2000 and XP."

Anyway, Windows may be a platform full of weird behaviors, but it is
very good at maintaining backward compatibility, so my guess is that
the MSI provided on the website should be able to work just fine with
2008R2.
--
Michael