Subject: Unable to compile psqlodbc on unix - Missing configure script in psqlodbc beyond version 16

From: Abhishek Kumar <[email-masked]>
Date: Mon, 18 Nov 2024 17:15:10 +0530

Hi,

I am trying to build the latest version of psqlodbc for Unix
REL-17_00_0002-mimalloc.
The configure/make file seems to be missing from the zip.

In all the versions of psqlodbc after version 16, the configure/make files
are missing.

I am using the
https://github.com/postgresql-interfaces/psqlodbc/releases/tag/REL-17_00_0002-mimalloc
hosted location to get the builds.

Can you please confirm if this a known issue and when can we have a fix for
this?

Is there an alternate way to build?

Regards,
Abhishek Kumar

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 18 Nov 2024 14:57:20 +0300

Hi,

On Mon, 2024-11-18 at 17:15 +0530, Abhishek Kumar wrote:
> In all the versions of psqlodbc after version 16, the configure/make
> files are missing.
> 
> I am using the
> Can you please confirm if this a known issue and when can we have a
> fix for this?

You need to run

autoreconf -i

prior to running configure script.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Dave Cramer <[email-masked]>
Date: Mon, 18 Nov 2024 07:04:26 -0500

Please post this issue on github

Thanks & Regards
Dave Cramer
www.postgres.rocks

On Mon, 18 Nov 2024 at 06:45, Abhishek Kumar <[email-masked]>
wrote:

> Hi,
>
> I am trying to build the latest version of psqlodbc for Unix REL-17_00_0002-mimalloc.
> Can you please confirm if this a known issue and when can we have a fix
> for this?
>