Subject: Invalid WAL segment size. Allowed values are 1,2,4,8,16,32,64

From: Cocco Gianfranco <[email-masked]>
Date: Fri, 9 Jun 2017 13:55:04 +0000

Hi,
We have a big problem with managing the number of WAL products, during database activity, so I would try to write to you.
With pg_rman utility, we can't save thousands of WAL files every few hours, to be used for a possible recovery.
We are using a production environment 9.2 PostgreSQL server which processes a database of about 260 GB
Is there a way to fix "wal_segsize" to about 1 Gb in 9.2. version, and "rebuild" postgreSQL server?
The goal is to drastically reduce the number of WALs.

Upgrading to 9.5, is the only way to fix this issue?

Thank you.

[Descrizione: cid:[email-masked]]
_______________________________

Gianfranco Cocco
Gruppo DBA Torino
Managed Operations - Data Center Factory
[email-masked]<mailto:[email-masked]>
Engineering.MO S.p.A
Corso Mortara, 22 - 10149 Torino
Tel. 011 19449548 (SHORT CODE: 676548)
www.eng.it<http://www.eng.it>

___________________________

---

From: Michael Paquier <[email-masked]>
Date: Sat, 10 Jun 2017 07:43:00 +0900

On Fri, Jun 9, 2017 at 10:55 PM, Cocco Gianfranco
<[email-masked]> wrote:
> Is there a way to fix “wal_segsize” to about 1 Gb in 9.2. version, and “rebuild” postgreSQL server?

As long as you are able to compile your own version of Postgres and
your distribution does not allow that, there is nothing preventing you
to do so.

> Upgrading to 9.5, is the only way to fix this issue?

Note that a server initialized with a segment size of X won't work
with a binary compiled with a size of Y. But you can always take a
logical dump of the server before the upgrade, and reload it in the
version of the server with a larger segment size. The cost here is
more downtime.
-- 
Michael

-- 
Sent via pgsql-bugs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-bugs

---

From: Jeff Janes <[email-masked]>
Date: Mon, 12 Jun 2017 10:27:58 -0700

> your distribution does not allow that, there is nothing preventing you

But there is something preventing it.  wal_segsize cannot exceed 64MB in
9.2. v10 will be the first version which will allow sizes above 64MB.

Cheers,

Jeff

---

From: Michael Paquier <[email-masked]>
Date: Tue, 13 Jun 2017 06:25:57 +0900

> 9.2. v10 will be the first version which will allow sizes above 64MB.

Yes, indeed. I have misread --with-segsize and --with-wal-segsize in
the docs. Sorry for the confusion.
-- 
Michael

---

From: Cocco Gianfranco <[email-masked]>
Date: Tue, 13 Jun 2017 09:10:50 +0000

Thank you.

If I understand it well, we can build a new postgreSQL server, by setting this value into "configure" file?

--with-wal-segsize=SEGSIZE   becomes  --with-wal-segsize=1024  ??

Gianfranco Cocco

Gruppo DBA Torino

[email-masked]

Engineering.MO S.p.A

www.eng.it

-----Messaggio originale-----
Da: Michael Paquier [mailto:[email-masked]]
Inviato: lunedì 12 giugno 2017 23:26
A: Jeff Janes <[email-masked]>
Cc: Cocco Gianfranco <[email-masked]>; [email-masked]; [email-masked]; DBA <[email-masked]>
Oggetto: Re: [BUGS] Invalid WAL segment size. Allowed values are 1,2,4,8,16,32,64

On Tue, Jun 13, 2017 at 2:27 AM, Jeff Janes <[email-masked]<mailto:[email-masked]>> wrote:

> But there is something preventing it.  wal_segsize cannot exceed 64MB

> in 9.2. v10 will be the first version which will allow sizes above 64MB.

Yes, indeed. I have misread --with-segsize and --with-wal-segsize in the docs. Sorry for the confusion.

--

Michael

---

From: Michael Paquier <[email-masked]>
Date: Tue, 13 Jun 2017 18:34:20 +0900

> --with-wal-segsize=SEGSIZE   becomes  --with-wal-segsize=1024  ??

Yes, but as Jeff has pointed out upthread, this value can just go up
to 64 when using 9.5.
-- 
Michael

-- 
Sent via pgsql-performance mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-performance

---

From: Michael Paquier <[email-masked]>
Date: Wed, 14 Jun 2017 05:38:52 +0900

On Tue, Jun 13, 2017 at 10:39 PM, Cocco Gianfranco
<[email-masked]> wrote:
> ./configure --with-wal-segsize=1024
>
> checking for WAL segment size... configure: error: Invalid WAL segment size.
> Allowed values are 1,2,4,8,16,32,64.
>
> Please, how can I do?

When trying to compile Postgres 9.6, the maximum value is 64. If you
want to allow 1GB of WAL segment size you will need to wait for 10, or
just use 64MB.
-- 
Michael