Subject: Debian bookworm install

From: Peter Ijewski <[email-masked]>
Date: Mon, 9 Oct 2023 13:30:53 +0200

Hi,

I encounter a problem in installing postgresql-16 on Devbian bookworm:

# apt install postgresql-16
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
postgresql-16 : Depends: postgresql-common (>= 252~) but 242.pgdg100+1 
is to be installed
E: Unable to correct problems, you have held broken packages.

Can anybody help?

Regards

Peter

-- 
*Dr. Peter Ijewski & Partner*

Mozartstr. 18
72160 Horb am Neckar

Tel.: 07451-51455

---

From: Sergei Kornilov <[email-masked]>
Date: Mon, 09 Oct 2023 15:16:39 +0300

Hi

pgdg100 in package version means debian buster (10), check sources.list and sources.list.d/ on this system. I'm guessing that source lines from previous debian releases may have gotten mixed up.

I installed postgresql 16 on debian bookworm few days ago without any surprises.

regards, Sergei