Subject: Extension packages not visible / available for postgres 12 yet ?

From: Sander Eikelenboom <[email-masked]>
Date: Fri, 4 Oct 2019 10:33:20 +0200

L.S.,

While trying to upgrade to postgres 12, it seems some xxtension packages not visible / available for postgres 12 yet ?

My sources list contains the apt.postgresql.org repo and I don't get any error while running apt update: 
	deb http://apt.postgresql.org/pub/repos/apt/ buster-pgdg main 12

For example i can't find with apt / aptitude:
	postgresql-12-pgrouting
	postgresql-12-postgis-2.x

Are these packages unavailable yet ?
If so do you have any idea when the will get available ?

--

Sander

---

From: Christoph Berg <[email-masked]>
Date: Fri, 4 Oct 2019 10:57:56 +0200

Re: Sander Eikelenboom 2019-10-04 <[email-masked]>
> 	postgresql-12-postgis-2.x

There is no postgresql-12-postgis-2.5 package because 3.0 is already
in the pipeline, and unfortunately we can't build both because that's
both the same "postgis" source package, with no version number in the
package*name. (That's why for PostgreSQL, the source packages are
called postgresql-11 postgresql-12 ...)

> If so do you have any idea when the will get available ?

postgresql-12-pgrouting isn't there yet because so far, the
postgresql-*-postgis-* packages had weird requirements wrt the
-scripts packages being installed, and that will only get sorted with
postgis 3. Possibly earlier, but things are unfortunately complicated.

Christoph

---

From: Sander Eikelenboom <[email-masked]>
Date: Fri, 4 Oct 2019 12:15:31 +0200

> postgis 3. Possibly earlier, but things are unfortunately complicated.

Hi Christoph,

I got the impression it should work from https://postgis.net/ where it states: 
	2.5.3 This release supports PostgreSQL 9.3-12 
	You are encouraged to use the PostGIS 3.0 unreleased branch with PostgreSQL 12 , 
	which has features specifically designed to take advantage of features new in PostgreSQL 12.

But as i understand it's mostly a packaging problem. 
Thanks for the info, I will just wait for postgis 3 for those specific databases that use this extension !

--
Sander

---

From: Christoph Berg <[email-masked]>
Date: Fri, 4 Oct 2019 12:29:34 +0200

Re: Sander Eikelenboom 2019-10-04 <[email-masked]>
> But as i understand it's mostly a packaging problem. 

Solely packaging, yes.

Christoph