Subject: Bug on postgresql-server-dev-11

From: Alejandro Grinberg <[email-masked]>
Date: Tue, 18 Feb 2020 16:08:39 -0300

With version 11.7-1.pgdg90+1 (released on  2020-Feb-13), when executing
"pg_config --pgxs", i got

*/usr/lib/postgresql/12/lib/pgxs/src/makefiles/pgxs.mk <http://pgxs.mk>*

when i should get

*foo/postgresql/12/bar*

---

From: Christoph Berg <[email-masked]>
Date: Tue, 18 Feb 2020 21:49:20 +0100

Re: Alejandro Grinberg 2020-02-18 <[email-masked]>
> */usr/lib/postgresql/12/lib/pgxs/src/makefiles/pgxs.mk <http://pgxs.mk>*

Do you have postgresql-server-dev-12 installed?

You are supposed to call pg_config with full path if you rely on a
specific version.

make USE_PGXS=1 PG_CONFIG=/usr/lib/postgresql/11/bin/pg_config

Christoph