Subject: pgAdmin4 stuck at version 4.18?

From: Erwin Brandstetter <[email-masked]>
Date: Wed, 8 Apr 2020 17:59:17 +0200

Hi!

pgAdmin4 versions 4.19 and 4.20 are out, but the repo seems to be stuck on
4.18?

https://apt.postgresql.org/pub/repos/apt/pool/main/p/pgadmin4/

Updates seems to have stopped in Feb?

https://www.postgresql.org/message-id/E1j1DAP-0003Ql-6H%40atalia.postgresql.org

Anything wrong with the new versions? Or should I just be patient?
(I reported a bug in pgAdmin4 that's supposed to be fixed, but seems like
it isn't. Waiting to check on Debian / Ubuntu before reporting back.)

Regards
Erwin

---

From: Christoph Berg <[email-masked]>
Date: Fri, 10 Apr 2020 16:42:49 +0200

Re: Erwin Brandstetter 2020-04-08 <[email-masked]>
> Anything wrong with the new versions? Or should I just be patient?

That's just me not having found the time for it yet. I'll push it up
on the TODO list.

> it isn't. Waiting to check on Debian / Ubuntu before reporting back.)

Christoph

---

From: Hynek Vychodil <[email-masked]>
Date: Mon, 4 May 2020 16:13:03 +0200

Hello,
there should be pgadmin4 for  Ubuntu 20.04 (focal) according to
https://wiki.postgresql.org/wiki/Apt
but there isn't.

$ cat /etc/apt/sources.list.d/pgdg.list
deb http://apt.postgresql.org/pub/repos/apt/ focal-pgdg main
$ sudo apt update
Ign:1 http://binaries.erlang-solutions.com/debian focal InRelease
Hit:2 http://binaries.erlang-solutions.com/debian focal Release
Hit:3 http://apt.postgresql.org/pub/repos/apt focal-pgdg InRelease
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:5 https://repo.skype.com/deb stable InRelease
Hit:6 https://deb.nodesource.com/node_12.x focal InRelease
Hit:7 https://download.docker.com/linux/ubuntu eoan InRelease
Hit:8 http://dl.google.com/linux/chrome/deb stable Release
Get:10 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Hit:11 http://cz.archive.ubuntu.com/ubuntu focal InRelease
Hit:12 http://cz.archive.ubuntu.com/ubuntu focal-updates InRelease
Get:13 http://cz.archive.ubuntu.com/ubuntu focal-backports InRelease [98.3
kB]
Fetched 205 kB in 1s (176 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as
repository 'http://apt.postgresql.org/pub/repos/apt focal-pgdg InRelease'
doesn't support architecture 'i386'
$ sudo apt-get install pgadmin4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package pgadmin4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'pgadmin4' has no installation candidate

---

From: Christoph Berg <[email-masked]>
Date: Tue, 12 May 2020 19:23:04 +0200

Hi,

I've updated the pgadmin4 package to 4.21, including on focal.

Christoph