Subject: postgis-update introduced dependency for postgresql-13

From: Hu Bert <[email-masked]>
Date: Wed, 28 Oct 2020 06:52:06 +0100

Hi,

i already wrote to the pgsql-general mailing list, there the
recommendation was to contact the package maintainers.

https://www.postgresql.org/message-id/CAAV-988tVaJi4oRe0WxUkA-6WkiawsgA_XWX93LoiGEtMuRxKA%40mail.gmail.com

It seems like that the last postgis update has introduced a dependency
to postgresql-13. More details here:

https://www.postgresql.org/message-id/CAAV-989nKHSVeqVaCvt5eikU8sSNNX_wkf7k8J8dyGxqxYc40A%40mail.gmail.com

Is there any reason for this dependency?

Best regards,
Hubert

---

From: Christoph Berg <[email-masked]>
Date: Mon, 2 Nov 2020 22:37:28 +0100

Re: Hu Bert
> https://www.postgresql.org/message-id/CAAV-989nKHSVeqVaCvt5eikU8sSNNX_wkf7k8J8dyGxqxYc40A%40mail.gmail.com

Hi Hubert,

the issue is likely this:

Package: postgis
Version: 3.0.2+dfsg-4.pgdg100+1
Recommends: postgresql-13-postgis-3, postgis-doc

If you have "install recommends" activated in the apt config (the
default), then installing "postgis" will also install the recommended
packages.

Compare:

$ sudo apt install postgis
Die folgenden NEUEN Pakete werden installiert:
  postgis postgis-doc postgresql-13 postgresql-13-postgis-3 postgresql-13-postgis-3-scripts
  postgresql-client-13

$ sudo apt install --no-install-recommends postgis
Die folgenden NEUEN Pakete werden installiert:
  postgis

I think we can change that to "Recommends: postgresql-postgis", will
do so for the next version.

Christoph

---

From: Hu Bert <[email-masked]>
Date: Tue, 3 Nov 2020 08:02:03 +0100

Hi Christoph,

yeah, that might explain everything. Thx for checking and fixing :-)

Best regards,
Hubert