Subject: Debian bullseye - upgrade to postgresql 15.1 broke apt-get

From: Alexandre Pereira bühler<[email-masked]>
Date: Mon, 14 Nov 2022 13:35:17 -0300

I can't install other packages due to dependency on dbconfig-common 2.0.22

see below:

root@backup:/etc/apt# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading status information... Ready
Calculating update... Done
0 packages updated, 0 new packages installed, 0 to be removed and 0 not 
updated.
root@backup:/etc/apt# apt-get install bacula-postgresql
Reading package lists... Done
Building dependency tree... Done
Reading status information... Ready
Some packages could not be installed. This could mean that
you requested an impossible situation or, if you are using the
unstable distribution, that some required packages were not
created yet or were withdrawn from "Incoming".
The following information may help resolve the situation:

The following packages have mismatched dependencies:
postgresql-15 : Break: dbconfig-common (< 2.0.22~) but 2.0.19 is about 
to be installed
E: Unable to fix problems, you kept (hold) broken packages.

-- 
Alexandre Pereira Bühler
Simão &  Bühler Ltda (Infobrindes)
http://www.simaoebuhler.com.br
[email-masked]
Telefone: (41) 99831-7470

---

From: Christoph Berg <[email-masked]>
Date: Tue, 15 Nov 2022 18:03:05 +0100

Re: Alexandre Pereira bühler
> The postgresql 15.1 update tries to install the dbconfig-common 2.0.22
> package which breaks the roundcube dependency.

Hi,

the problem is that dbconfig-common older than that version is
incompatible with PG15's stricter permissions on the built-in default
public schema.

The updated dbconfig-common version is available via backports (at
least in bullseye).

I'll see if we can include that version in our repo as well.

Christoph

---

From: Alexandre Pereira bühler<[email-masked]>
Date: Tue, 15 Nov 2022 19:11:49 -0300

Hello,
In debian backports do not have the package in the requested version 2.0.22.

---

From: Alexandre Pereira bühler<[email-masked]>
Date: Tue, 15 Nov 2022 19:16:46 -0300

Hi,
I saw that you put the requested dbconfig-common in the repository.
Thanks