Subject: Not working Bookworm-pgdg repo

From: Vojtěch Dušátko <[email-masked]>
Date: Wed, 18 Feb 2026 14:19:08 +0100

Hello,

I have a problem that /apt update/ fails with error in pgdg repo. Can 
someone please take a look at it? I can see the issue for a few days now.

# apt update
Hit:1http://ftp.cz.debian.org/debian bookworm InRelease
Hit:2http://ftp.cz.debian.org/debian bookworm-updates InRelease
Hit:3http://security.debian.org/debian-security bookworm-security InRelease
Get:4http://apt.postgresql.org/pub/repos/apt bookworm-pgdg InRelease [107 kB]
Hit:5http://haproxy.debian.net bookworm-backports-2.6 InRelease
Hit:6http://haproxy.debian.net bullseye-backports-2.6 InRelease
Get:7http://apt.postgresql.org/pub/repos/apt bookworm-pgdg/main amd64 Packages [408 kB]
Err:7http://apt.postgresql.org/pub/repos/apt bookworm-pgdg/main amd64 Packages
   File has unexpected size (408676 != 407760). Mirror sync in progress? [IP: 146.75.123.52 80]
   Hashes of expected file:
    - Filesize:407760 [weak]
    - SHA256:d2dfe5e2cfb90c2849616207f72afb996dc177533b6e9acd4269b0fe18982c24
    - SHA1:c1af37094108982f088408b65755f1d7d396d930 [weak]
    - MD5Sum:24738e12adcb21b013eaeccb37e4e1d8 [weak]
   Release file created at: Thu, 12 Feb 2026 11:13:19 +0000
Reading package lists... Done
E: Failed to fetchhttp://apt.postgresql.org/pub/repos/apt/dists/bookworm-pgdg/main/binary-amd64/Packages.bz2  File has unexpected size (408676 != 407760). Mirror sync in progress? [IP: 146.75.123.52 80]
    Hashes of expected file:
     - Filesize:407760 [weak]
     - SHA256:d2dfe5e2cfb90c2849616207f72afb996dc177533b6e9acd4269b0fe18982c24
     - SHA1:c1af37094108982f088408b65755f1d7d396d930 [weak]
     - MD5Sum:24738e12adcb21b013eaeccb37e4e1d8 [weak]
    Release file created at: Thu, 12 Feb 2026 11:13:19 +0000
E: Some index files failed to download. They have been ignored, or old ones used instead.

Thank you

-- 
Vojtěch Dušátko

---

From: Christoph Berg <[email-masked]>
Date: Wed, 18 Feb 2026 14:40:55 +0100

Re: Vojtěch Dušátko
>   Release file created at: Thu, 12 Feb 2026 11:13:19 +0000

We've had several reports about this problems, afaict all with this
timestamp. The actual file is newer.

The cloud CDN in front is probably caching bad things there...

Maybe the PG infra admins could check?

Christoph

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 18 Feb 2026 15:17:39 +0100

> Maybe the PG infra admins could check?
Hi!

This problem is still ongoing, right? Could you run:

curl -D -
http://apt.postgresql.org/pub/repos/apt/dists/bookworm-pgdg/InRelease >
curled_InRelease
curl -D -
http://apt.postgresql.org/pub/repos/apt/dists/bookworm-pgdg/main/binary-amd64/Packages
> curled_Packages
curl -D -
http://apt.postgresql.org/pub/repos/apt/dists/bookworm-pgdg/main/binary-amd64/Packages.bz2
> curled_Packages.bz2

And send those two files?

(And it has to be run from the same machine you run apt on, since the CDN
might direct other machines to other nodes)

Thanks!

//Magnus

---

From: Vojtěch Dušátko <[email-masked]>
Date: Wed, 18 Feb 2026 15:22:24 +0100

Hello,

I can't see the problem anymore, right now.

If you cleaned up something, thank you.

If not - some weird behavior happened. I have multiple psql clusters 
hidden under same public IP (NAT) and now I can't see the same behavior 
at any node of the farm.

Thank you.

Vojtěch Dušátko

On 18/02/26 15:17, Magnus Hagander wrote:
> http://apt.postgresql.org/pub/repos/apt/dists/bookworm-pgdg/InRelease 
> > curled_InRelease
> curl -D - 
> (And it has to be run from the same machine you run apt on, since the 
> CDN might direct other machines to other nodes)
>
> Thanks!
>
> //Magnus
>

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 18 Feb 2026 15:26:47 +0100

Hi!

Nope, nothing was done :(

Do you happen to have a record of the time you first saw the problem?

I can see that the file you got has been in the closest cache for a bit
over two hours. When you sent your report in an hour ago, was that right
when you had the problem, or could there have been time between when you
got the error out and when you sent the email, and that the actual attempt
could have been more than 2 hours ago?

Thanks!

//Magnus

On Wed, 18 Feb 2026 at 15:23, Vojtěch Dušátko <[email-masked]> wrote:

> hidden under same public IP (NAT) and now I can't see the same behavior at
> any node of the farm.
>
> Thank you.
>
> Vojtěch Dušátko
>

---

From: Vojtěch Dušátko <[email-masked]>
Date: Wed, 18 Feb 2026 15:42:56 +0100

First I saw this error was at some machine (same external IP) yesterday.
I was facing the issue today but not sure - I think that the last error was right before I sent an email. I'm not 100% sure, NGL.

⁣---
Vojtěch Dušátko​

On Feb 18, 2026, 15:27, at 15:27, Magnus Hagander <[email-masked]> wrote:
>CDN

---

From: Vojtěch Dušátko <[email-masked]>
Date: Wed, 18 Feb 2026 21:53:52 +0100

Now I can confirm the time exactly ...

[130] [21:52:49] root@psql15-test-is-01:~# date
Wed Feb 18 09:52:52 PM CET 2026
[21:52:52] root@psql15-test-is-01:~# apt update
[100] [21:52:55] root@psql15-test-is-01:~#

Vojtěch Dušátko

On 18/02/26 15:42, Vojtěch Dušátko wrote:
> I was facing the issue today but not sure - I think that the last 
> error was right before I sent an email. I'm not 100% sure, NGL.
>
> ---
> Vojtěch Dušátko
> On Feb 18, 2026, at 15:27, Magnus Hagander <[email-masked]> wrote:
>
>     Hi!
>
>     I can see that the file you got has been in the closest cache for
>     a bit over two hours. When you sent your report in an hour ago,
>     was that right when you had the problem, or could there have been
>     time between when you got the error out and when you sent the
>     email, and that the actual attempt could have been more than 2
>     hours ago?
>
>     Thanks!
>
>     //Magnus
>
>
>         If not - some weird behavior happened. I have multiple psql
>         clusters hidden under same public IP (NAT) and now I can't see
>         the same behavior at any node of the farm.
>
>         Thank you.
>
>         Vojtěch Dušátko
>
>>         (And it has to be run from the same machine you run apt on,
>>         since the CDN might direct other machines to other nodes)
>>
>>         Thanks!
>>
>>         //Magnus
>>
>

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 18 Feb 2026 22:18:12 +0100

Excellent. Can you also provide me (off-list if you don't want it public)
the public IP address you're connecting from? You said you were all behind
the same NAT?

//Magnus

On Wed, 18 Feb 2026 at 21:54, Vojtěch Dušátko <[email-masked]> wrote:

> Hit:1 http://ftp.cz.debian.org/debian bookworm InRelease
> Hit:2 http://ftp.cz.debian.org/debian bookworm-updates InRelease
> Hit:3 http://security.debian.org/debian-security bookworm-security InRelease
> Get:4 http://apt.postgresql.org/pub/repos/apt bookworm-pgdg InRelease [107 kB]
> Hit:5 http://haproxy.debian.net bookworm-backports-2.6 InRelease
> Hit:6 http://haproxy.debian.net bullseye-backports-2.6 InRelease
> Get:7 http://apt.postgresql.org/pub/repos/apt bookworm-pgdg/main amd64 Packages [408 kB]
> Err:7 http://apt.postgresql.org/pub/repos/apt bookworm-pgdg/main amd64 Packages
> E: Failed to fetch http://apt.postgresql.org/pub/repos/apt/dists/bookworm-pgdg/main/binary-amd64/Packages.bz2  File has unexpected size (408676 != 407760). Mirror sync in progress? [IP: 146.75.123.52 80]
>    Hashes of expected file:
>     - Filesize:407760 [weak]
> I was facing the issue today but not sure - I think that the last error
> was right before I sent an email. I'm not 100% sure, NGL.
>
> ---
> Vojtěch Dušátko