Subject: Postgresql15 and PostGIS

From: Mike Sijmons <[email-masked]>
Date: Mon, 10 Jul 2023 16:20:08 +0000

Hello,

I hope ask this question to the right people

I see in the repository of the community PostGIS up to Postgresql version 14 but not for Postgres 15

This is regarding the Ubuntu OS.

Any reason why PostGIS for 15 is not there? Or can we expect it soon?

Or is 14 the only viable option?

Kind regards,

Mike Sijmons
Nibble-IT BV

Mike Sijmons
CTO

E: [email-masked]
M: +31 6 53 36 45 21
W: www.nibble-it.nl<http://www.nibble-it.nl/>

Binnendelta 1-U2  | 1261 WZ  Blaricum  | Nederland

This email and its attachments are confidential and may contain legally privileged information. You should not disclose the contents to any other person. If you are not the intended recipient, please notify the sender immediately and delete this email from your system.

---

From: Sergei Kornilov <[email-masked]>
Date: Mon, 10 Jul 2023 19:36:34 +0300

Hello
postgresql-15-postgis-3 is available is repo.
What operating system are you using? Maybe it's something near/already EOL?

regards, Sergei

---

From: Mike Sijmons <[email-masked]>
Date: Mon, 10 Jul 2023 16:43:16 +0000

Hello, 

Thank you for your quick response!

We currently running Ubuntu 18.04 and Postgres 10.23.

First we migrate to Postgres 14 or 15 depending in the availability of the PostGis extension

And than we upgrade to Ubuntu 20.04 

That is the plan! 

If I do an "apt-cache search postgresql-15 | grep -i postgis" I do not get any hits also not on " apt-cache search postgresql-15-postgis-3"

I added the repository with:

sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt $(lsb_release -cs)-pgdg main" > /etc/apt/sources.list.d/pgdg.list'
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

Kind regards,
Mike

-----Original Message-----
From: Sergei Kornilov <[email-masked]> 
Sent: Monday, 10 July 2023 18:37
To: Mike Sijmons <[email-masked]>
Cc: [email-masked]
Subject: Re:Postgresql15 and PostGIS

Hello

regards, Sergei

---

From: Sergei Kornilov <[email-masked]>
Date: Mon, 10 Jul 2023 19:56:51 +0300

Hi

> We currently running Ubuntu 18.04 and Postgres 10.23.

That's what I thought. Correct, postgresql-15-postgis-3 was not packaged for for ubuntu 18.04.
I don't know the backstory, maybe because it was only a few months from the postgresql 15 release to the EOL of this ubuntu release, or there were issues with the build. But there are no packages and now they are definitely not expected to appear.

regards, Sergei

---

From: Mike Sijmons <[email-masked]>
Date: Mon, 10 Jul 2023 16:59:06 +0000

Hello Sergei, 

Thanks again for your quick response. 

Kind regards,
Mike

-----Original Message-----
From: Sergei Kornilov <[email-masked]> 
Sent: Monday, 10 July 2023 18:57
To: Mike Sijmons <[email-masked]>
Cc: [email-masked]
Subject: Re: Postgresql15 and PostGIS

Hi

regards, Sergei

---

From: Christoph Berg <[email-masked]>
Date: Tue, 11 Jul 2023 20:47:57 +0200

The current PostGIS version does not compile anymore on Ubuntu bionic. I forgot the reason, but there was one...

Furthermore, there will be no more builds on apt.pg.o for bionic at all since PostgreSQL 16 doesn't build there anymore either, so I removed it from the build config.

I'll shortly post a proper EOL announcement here.

Christoph