Subject: Re: Bug#834129: pgadmin4 adopter wanted

From: William Bonnet <[email-masked]>
Date: Mon, 19 Oct 2020 15:16:14 +0200

Hi Christoph,

First of all i do apologize for my late answer, something went wrong on my side with email delivery... :(

> do you have experience with Debian packaging? You'll likely have to
> work on packaging or updating Python module packages in Debian as well.

Yes I do, I have often made packages either at office or as a hobby, i created a framework to automatically build Debian packages for kernel and uboot from upstream sources (https://github.com/wbonnet/dft).

Since it's a different and long story i'll be happy to share and discuss about this, maybe in another email ;)

I am not ( yet ;) ) a Debian maintainer, but i have been for several years a Solaris maintainer in OpenCSW and Blastwave for software like Firefox Thunder bird or Xfce, working with upstram communities and submitting portability patches to compile and work under solaris.

Its a different platform and toolchain, but still a maintainer work.

In short :) i know what i am doing by applying to maintain a PG tool package :) it is going to be a lot of work, and i have checked that enough free time time in the coming months to handle this.

> Plus debugging the whole stack on older Debian/Ubuntu releases.

I am running several builders and PG servers under different versions, i can easily adapt my infrastructure to test this and host different reference and test VMs.

I was expecting to have this work to do and of course to with Ubuntu and Postgresql maintainers and community.

I'll be really happy to collaborate with the other communities and share the effort.

I propose to start on my side by upgrading  your pckage to latest  restarting  from existing package definition and let you knwow and see how things are going.

Let me know please what information you may need, and don't hesitate if you have advices on the steps to follow. I expect to start with upgrade and non regression tests. 

Kind regards,
William

PS: I'm sorry i hove to restart a new mail instead of a true reply,
something went really bad on my email side :(

---

From: Christoph Berg <[email-masked]>
Date: Tue, 3 Nov 2020 16:27:37 +0100

Re: William Bonnet
> First of all i do apologize for my late answer, something went wrong on my side with email delivery... :(

Hi William,

the last week was very busy and I was just too tired to answer
earlier, sorry for that.

> In short :) i know what i am doing by applying to maintain a PG tool package :) it is going to be a lot of work, and i have checked that enough free time time in the coming months to handle this.

That sounds perfect. Thanks for volunteering.

> I was expecting to have this work to do and of course to with Ubuntu and Postgresql maintainers and community.

Ideally the package would be included in Debian and Ubuntu, but that
needs the whole "Javascript needs packing and proper licenses" issue
resolved first which will not be easy.

Until that happens, we have the packages on apt.postgresql.org, where
it is built for the Debian and Ubuntu distributions.

Another question is if "our" package needs adjustments now that
pgadmin4 upstream has published their own packages with a completely
different layout. (At the very least we should probably "Conflict:"
with their packages so users don't get into a mess when they have
installed both. Or maybe that's not a problem and having both works.)

> I propose to start on my side by upgrading  your pckage to latest  restarting  from existing package definition and let you knwow and see how things are going.

The packaging repository is https://salsa.debian.org/postgresql/pgadmin4 .
I suggest you get an account there, and clone the repository to work
on. I can also get you privileges to trigger builds for
https://pgdgbuild.dus.dg-i.net/job/pgadmin4/ and the related build
jobs there.

Christoph