Subject: pgadmin3 1.22.2-6 broken

From: Erwin Brandstetter <[email-masked]>
Date: Wed, 8 Jan 2020 16:39:39 +0100

I am running Ubuntu bionic with the additional repository:

deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main

pgadmin3 was updated to version 1.22.2-6.pgdg18.04+1 when I ran updates
today. Now I cannot open the essential SQL editor any more. I see a
black-and-white wireframe for a second or two, then the program terminates.
The program is now useless for me.

The log file for pgAdmin 3 ends with:

...
QUERY  : 16:32:19: Scalar query (:5432): SELECT version();
QUERY  : 16:32:19: Query result: PostgreSQL 11.6 (Ubuntu
11.6-1.pgdg18.04+1) on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu
7.4.0-1ubuntu1~18.04.1) 7.4.0, 64-bit
QUERY  : 16:32:19: Set query (:5432): SET DateStyle=ISO;
SET client_min_messages=notice;
SET bytea_output=escape;
SELECT oid, pg_encoding_to_char(encoding) AS encoding, datlastsysoid
  FROM pg_database WHERE oid = 16385
SCRIPT : 16:32:19: Application created

/var/log/syslog seems revealing:

Jan  8 16:32:19 A-N-W-030 pgadmin3[4674]: The window 0x56464b1d84d0 already
has a drawing context. You cannot call gdk_window_begin_draw_frame()
without calling gdk_window_end_draw_frame() first.
Jan  8 16:32:19 A-N-W-030 kernel: [ 3812.954406] pgadmin3[4674]: segfault
at 4 ip 00007f40917a21a0 sp 00007ffcb697bc58 error 4 in
libcairo.so.2.11510.0[7f4091782000+118000]
Jan  8 16:32:19 A-N-W-030 pgadmin3[4674]:
gdk_drawing_context_get_cairo_context: assertion 'GDK_IS_DRAWING_CONTEXT
(context)' failed

Any way to fix? Or get the previous version? I tried:

sudo apt-get install pgadmin3=1.22.2-5

But only get the error:
> E: Version '1.22.2-5' for 'pgadmin3' was not found

Regards
Erwin

---

From: Erwin Brandstetter <[email-masked]>
Date: Wed, 8 Jan 2020 17:10:52 +0100

The downgrade to 1.22.2-4 fixed it for me for now:

sudo apt-get install pgadmin3=1.22.2-4 pgadmin3-data=1.22.2-4
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  libwxgtk3.0-gtk3-0v5 python3-flask-htmlmin python3-htmlmin
Use 'sudo apt autoremove' to remove them.
The following packages will be DOWNGRADED:
  pgadmin3 pgadmin3-data
0 upgraded, 0 newly installed, 2 downgraded, 0 to remove and 0 not upgraded.
Need to get 5.065 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://at.archive.ubuntu.com/ubuntu bionic/universe amd64 pgadmin3
amd64 1.22.2-4 [3.187 kB]
Get:2 http://at.archive.ubuntu.com/ubuntu bionic/universe amd64
pgadmin3-data all 1.22.2-4 [1.878 kB]
Fetched 5.065 kB in 2s (2.519 kB/s)
dpkg: warning: downgrading pgadmin3 from 1.22.2-6.pgdg18.04+1 to 1.22.2-4
(Reading database ... 176239 files and directories currently installed.)
Preparing to unpack .../pgadmin3_1.22.2-4_amd64.deb ...
Unpacking pgadmin3 (1.22.2-4) over (1.22.2-6.pgdg18.04+1) ...
dpkg: warning: downgrading pgadmin3-data from 1.22.2-6.pgdg18.04+1 to
1.22.2-4
Preparing to unpack .../pgadmin3-data_1.22.2-4_all.deb ...
Unpacking pgadmin3-data (1.22.2-4) over (1.22.2-6.pgdg18.04+1) ...
Setting up pgadmin3-data (1.22.2-4) ...
Setting up pgadmin3 (1.22.2-4) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

Regards
Erwin

On Wed, Jan 8, 2020 at 4:39 PM Erwin Brandstetter <[email-masked]>
wrote:

> Jan  8 16:32:19 A-N-W-030 pgadmin3[4674]: The window 0x56464b1d84d0
> already has a drawing context. You cannot call
> gdk_window_begin_draw_frame() without calling gdk_window_end_draw_frame()
> first.

---

From: Christoph Berg <[email-masked]>
Date: Mon, 13 Jan 2020 13:19:55 +0100

Re: Erwin Brandstetter 2020-01-08 <[email-masked]>
> gdk_drawing_context_get_cairo_context: assertion 'GDK_IS_DRAWING_CONTEXT

(Discussion continued at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=948549)

> > E: Version '1.22.2-5' for 'pgadmin3' was not found

Older versions are available in the morgue:

http://atalia.postgresql.org/morgue/
https://wiki.postgresql.org/wiki/Apt/FAQ#Where_are_older_versions_of_the_packages.3F

Christoph

---

From: Erwin Brandstetter <[email-masked]>
Date: Wed, 15 Jan 2020 15:48:35 +0100

Thank you Christoph!

I installed the new version 1.22.2-6.pgdg100+2 on Ubuntu bionic and the
reported segfaults are gone.

Regards
Erwin

On Mon, Jan 13, 2020 at 1:19 PM Christoph Berg <[email-masked]> wrote:

> Re: Erwin Brandstetter 2020-01-08 <
> [email-masked]>
> (Discussion continued at
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=948549)
>