Subject: Postgres 13 package on Debian 10 has unmet dependencies

From: Fernando Hevia <[email-masked]>
Date: Wed, 2 Jun 2021 20:47:06 -0300

Hi list.

As the subject states, I am facing an unmet dependency issue with libpq5
while installing Postgres 13 on Debian 10.9. (BTW, same thing happens with
PG 12).

I am using postgresql repository:

*# cat /etc/apt/sources.list.d/pgdg.list *
deb http://apt.postgresql.org/pub/repos/apt buster-pgdg main

*# apt install postgresql-13 postgresql-client-13*
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 postgresql-client-13 : Depends: libpq5 (>= 13.3) but 11.12-0+deb10u1 is to
be installed
E: Unable to correct problems, you have held broken packages.

When looking for libpq5 available versions only v11.12 is listed.

*# apt search libpq5*
Sorting... Done
Full Text Search... Done
libpq-dev/stable 11.12-0+deb10u1 amd64
  header files for libpq5 (PostgreSQL library)

libpq5/stable 11.12-0+deb10u1 amd64
  PostgreSQL C client library

libpq5-dbgsym/buster-pgdg 13.3-1.pgdg100+1 amd64
  debug symbols for libpq5

I could get around this by manually installing the correct libpq5 version,
but I still wanted to share this issue with the list. Could it be a
packaging error?

Thanks,
Fernando.

---

From: Aaron Pavely <[email-masked]>
Date: Wed, 2 Jun 2021 19:54:08 -0500

On Wed, Jun 2, 2021 at 6:47 PM Fernando Hevia <[email-masked]> wrote:

>  postgresql-client-13 : Depends: libpq5 (>= 13.3) but 11.12-0+deb10u1 is
> to be installed

Looks like there's a cross-over between Debian's own repository and the
PGDG repository. I suspect there's differing weights between the priorities
for each. What's the result of `apt-cache policy libpq5`?

Aaron

---

From: Fernando Hevia <[email-masked]>
Date: Wed, 2 Jun 2021 23:11:05 -0300

*# apt-cache policy libpq5*
libpq5:
  Installed: (none)
  Candidate: 11.12-0+deb10u1
  Version table:
     13.3-1.pgdg100+1 500
        500 http://apt.postgresql.org/pub/repos/apt buster-pgdg/main amd64
Packages
     11.12-0+deb10u1 990
        990 http://security.debian.org/debian-security buster/updates/main
amd64 Packages
     11.11-0+deb10u1 990
        990 http://ftp.us.debian.org/debian buster/main amd64 Packages

El mié, 2 de jun. de 2021 a la(s) 21:54, Aaron Pavely ([email-masked])
escribió:

>> I could get around this by manually installing the correct libpq5
>> version, but I still wanted to share this issue with the list. Could it be
>> a packaging error?
>>
>> Thanks,
>> Fernando.
>>
>

---

From: Aaron Pavely <[email-masked]>
Date: Wed, 2 Jun 2021 21:48:47 -0500

On Wed, Jun 2, 2021 at 9:11 PM Fernando Hevia <[email-masked]> wrote:

>         500 http://apt.postgresql.org/pub/repos/apt buster-pgdg/main
> amd64 Packages
>      11.12-0+deb10u1 990
>         990 http://security.debian.org/debian-security
> buster/updates/main amd64 Packages
>      11.11-0+deb10u1 990
Looks like your apt pinning policies for your Debian repositories are set
higher (990) than default (500). Is there a preference file changing the
default in `/etc/apt/preferences.d/`?
For reference:
https://wiki.postgresql.org/wiki/Apt/FAQ#I_want_only_specific_packages_from_this_repository
https://wiki.debian.org/AptConfiguration

Aaron

---

From: Fernando Hevia <[email-masked]>
Date: Thu, 3 Jun 2021 05:12:26 -0300

Thank you Aaron for your reply and pointing me to the appropriate
documentation.
It turns out there is no preference file on my system, which is supposed to
be a clean Debian 10.9 install. (Need to check with the servers team
though).

I managed to change the apt repository for libpq5 by creating a pgdg
preference file:

*# cat /etc/apt/preferences.d/pgdg.pref*
Package: *
Pin: release o=apt.postgresql.org
Pin-Priority: 991

*# apt-cache policy libpq5*
libpq5:
  Installed: (none)
  Candidate: 13.3-1.pgdg100+1
  Version table:
     13.3-1.pgdg100+1 991
        991 http://apt.postgresql.org/pub/repos/apt buster-pgdg/main amd64
Packages
     11.12-0+deb10u1 990
        990 http://security.debian.org/debian-security buster/updates/main
amd64 Packages
     11.11-0+deb10u1 990
        990 http://ftp.us.debian.org/debian buster/main amd64 Packages

While this is an improvement over manually installing the desired version
of libpq5, I am still confused about why this pin-priority 990 is the
default in my box.

Thanks again for your support.
Best regards,
Fernando.

El mié, 2 de jun. de 2021 a la(s) 23:48, Aaron Pavely ([email-masked])
escribió:

>>>> As the subject states, I am facing an unmet dependency issue with
>>>> libpq5 while installing Postgres 13 on Debian 10.9. (BTW, same thing
>>>> happens with PG 12).
>>>>
>>>>  postgresql-client-13 : Depends: libpq5 (>= 13.3) but 11.12-0+deb10u1
>>>> is to be installed