Subject: postgres user home dir

From: Don Seiler <[email-masked]>
Date: Fri, 2 Jun 2023 13:08:33 -0500

Good afternoon all,

Just writing to confirm that the postgresql-common package will _always_
create the postgres user to have its home directory in /var/lib/postgresql?
Is that configurable at all?

Thanks,
Don.

-- 
Don Seiler
www.seiler.us

---

From: Christoph Berg <[email-masked]>
Date: Sat, 03 Jun 2023 09:07:25 +0200

>Is that configurable at all?

Hi Don,

You can configure it by creating the user before installing the package 

Christoph

---

From: Don Seiler <[email-masked]>
Date: Sat, 3 Jun 2023 09:40:51 -0500

> You can configure it by creating the user before installing the package

Ok but otherwise the package will always use /var/lib/postgresql then if it
is the one creating the user?

Thanks,
Don.

---

From: Aaron Pavely <[email-masked]>
Date: Sat, 3 Jun 2023 12:07:26 -0500

On Sat, Jun 3, 2023 at 9:41 AM Don Seiler <[email-masked]> wrote:

> Ok but otherwise the package will always use /var/lib/postgresql then if
> it is the one creating the user?
>
> Thanks,
> Don.
>

Correct.

https://salsa.debian.org/postgresql/postgresql-common/-/blob/master/debian/postgresql-common.postinst#L31-35

Aaron