Subject: Bullseye 10 and 11 servers packages

From: Laurent Arnoud <[email-masked]>
Date: Fri, 5 Aug 2022 16:34:07 +0200

Hi,

I'm working at platform.sh and we are using your Debian packages for
all versions. We are trying to update to bullseye, but currently the
10 and 11 servers are missing from this repository. I can see that
there are builds successfully on your jenkins
[10](https://pgdgbuild.dus.dg-i.net/job/postgresql-10-binaries/architecture=amd64,distribution=bullseye/lastSuccessfulBuild/artifact/)
[11](https://pgdgbuild.dus.dg-i.net/job/postgresql-11-binaries/architecture=amd64,distribution=bullseye/lastSuccessfulBuild/artifact/)

Are these debs not intended to be included in the public repos, or can
we find them published elsewhere?

Thanks,
Laurent

---

From: Aaron Pavely <[email-masked]>
Date: Fri, 5 Aug 2022 13:56:23 -0500

On Fri, Aug 5, 2022 at 1:29 PM Laurent Arnoud <[email-masked]>
wrote:

> Hi,
>
> I'm working at platform.sh and we are using your Debian packages for all versions. We are trying to update to bullseye, but currently the 10 and 11 servers are missing from this repository. I can see that there are builds successfully on your jenkins [10](https://pgdgbuild.dus.dg-i.net/job/postgresql-10-binaries/architecture=amd64,distribution=bullseye/lastSuccessfulBuild/artifact/) [11](https://pgdgbuild.dus.dg-i.net/job/postgresql-11-binaries/architecture=amd64,distribution=bullseye/lastSuccessfulBuild/artifact/)
>
> Are these debs not intended to be included in the public repos, or can we find them published elsewhere?
>
> Thanks,
> Laurent
>
>
Are you using the 'main' component in your 'sources.list', or are you
selecting specifically '10' and/or '11'?

Correct:
deb http://apt.postgresql.org/pub/repos/apt *bullseye*-pgdg main

Incorrect:
deb http://apt.postgresql.org/pub/repos/apt *bullseye*-pgdg 10
deb http://apt.postgresql.org/pub/repos/apt *bullseye*-pgdg 11

The incorrect form is valid if you wish to use the libpq from a prior major
release, as detailed here:
https://wiki.postgresql.org/wiki/Apt/FAQ#I_want_libpq5_for_version_X.2C_but_there_is_only_version_Y_in_the_repository

While I don't use bullseye, it's easy to check if the package is referenced
in the repository (note the 'main' in the path):
$ curl -s
https://apt.postgresql.org/pub/repos/apt/dists/bullseye-pgdg/main/binary-amd64/Packages
| sed -n '/^Package: postgresql-10$/,/^$/p' | head -n 5
Package: postgresql-10
Version: 10.21-1.pgdg110+1
Architecture: amd64
Maintainer: Debian PostgreSQL Maintainers <
[email-masked]>
Installed-Size: 23691
$ curl -s
https://apt.postgresql.org/pub/repos/apt/dists/bullseye-pgdg/main/binary-amd64/Packages
| sed -n '/^Package: postgresql-11$/,/^$/p' | head -n 5
Package: postgresql-11
Version: 11.16-1.pgdg110+1
Architecture: amd64
Maintainer: Debian PostgreSQL Maintainers <
[email-masked]>
Installed-Size: 45958

Regards,
Aaron

---

From: Laurent Arnoud <[email-masked]>
Date: Mon, 8 Aug 2022 10:06:55 +0200

Hi Aaron,

Yes we are using main as source, but I think it failed because we are using
postgis-2.5 for pg10 and 11 and I was wrongly checking on the browser 14
Packages list instead of main. Thanks for the quick reply.

Cheers,
Laurent

On Fri, Aug 5, 2022 at 8:56 PM Aaron Pavely <[email-masked]> wrote:

> The incorrect form is valid if you wish to use the libpq from a prior
> major release, as detailed here:
>
> While I don't use bullseye, it's easy to check if the package is
> referenced in the repository (note the 'main' in the path):
> $ curl -s