Subject: pgvector 0.8.0 seems MIA?

From: Gwen Shapira <[email-masked]>
Date: Mon, 4 Nov 2024 21:35:49 -0500

Hi,

Pgvector 0.8.0 shipped on Oct 30.
I saw some release messages here:
https://salsa.debian.org/postgresql/pgvector/-/commits/develop?ref_type=HEADS
But when I check for the packages, I still don't see them:

wget -O-
https://apt.postgresql.org/pub/repos/apt/dists/noble-pgdg/main/binary-amd64/Packages
2>&1| ag "Package: postgresql-15-pgvector" -A2
Package: postgresql-15-pgvector
Source: pgvector
Version: 0.7.4-2.pgdg24.04+1
Package: postgresql-15-pgvector-dbgsym
Package-Type: ddeb
Source: pgvector

Did I miss anything? Is there any step that still has to run on your side?
Or on mine?
I'm sure I'm not the only user eager to use the latest pgvector.

Thanks in advance for your help,
Gwen

---

From: Aaron Pavely <[email-masked]>
Date: Mon, 4 Nov 2024 21:44:50 -0600

> Thanks in advance for your help,

Hi Gwen,

It's there, but it looks like it has not yet been promoted out of the
testing suites:

$ wget -q -O-
https://apt.postgresql.org/pub/repos/apt/dists/noble-pgdg-testing/main/binary-amd64/Packages
| sed -n '/^Package: postgresql-15-pgvector/,/^$/p'
Package: postgresql-15-pgvector
Source: pgvector
Version: 0.8.0-1.pgdg24.04+1
Architecture: amd64
Maintainer: Debian PostgreSQL Maintainers <
[email-masked]>
Installed-Size: 706
Depends: postgresql-15, postgresql-15-jit-llvm (>= 17), libc6 (>= 2.38)
Homepage: https://github.com/pgvector/pgvector
Priority: optional
Section: database
Filename:
pool/main/p/pgvector/postgresql-15-pgvector_0.8.0-1.pgdg24.04+1_amd64.deb
Size: 266536
SHA256: 2cf09022be27c764a10518fe08ca98ecb97ac5e7526203262ef8210e0542b5bf
SHA1: 674218ee94268ab28a434d8637f08cc4c80139cc
MD5sum: 970c4b23456d3744445a0cff6cbf6f79
Description: Open-source vector similarity search for Postgres
 Supports exact and approximate nearest neighbor search for L2 distance,
inner
 product, and cosine distance.

Package: postgresql-15-pgvector-dbgsym
Package-Type: ddeb
Source: pgvector
Version: 0.8.0-1.pgdg24.04+1
Auto-Built-Package: debug-symbols
Architecture: amd64
Maintainer: Debian PostgreSQL Maintainers <
[email-masked]>
Installed-Size: 371
Depends: postgresql-15-pgvector (= 0.8.0-1.pgdg24.04+1)
Priority: optional
Section: debug
Filename:
pool/main/p/pgvector/postgresql-15-pgvector-dbgsym_0.8.0-1.pgdg24.04+1_amd64.deb
Size: 313756
SHA256: 073d28a0a78b5b2b1c824ebd8c0f5abfe7994fadbf886dd0154a087c67f4429c
SHA1: 8f7f9f7785340efb773ff8db40ae210e105ac34f
MD5sum: 91d17a217e458cc121bb6adaa45ace85
Description: debug symbols for postgresql-15-pgvector
Build-Ids: c8d46e5e29785582a9e45ca791ee1ec35b168c24

You'll need to configure your repositories to include the
`noble-pgdg-testing` suite.

sudo sh -c 'echo "deb
[signed-by=/usr/share/postgresql-common/pgdg/apt.postgresql.org.asc]
https://apt.postgresql.org/pub/repos/apt $(lsb_release -cs)-pgdg-testing
main" > /etc/apt/sources.list.d/pgdg-testing.list'

Best regards,
Aaron

---

From: Christoph Berg <[email-masked]>
Date: Tue, 5 Nov 2024 16:47:07 +0100

Re: Aaron Pavely
> It's there, but it looks like it has not yet been promoted out of the

I tend not to do that immediately to allow some "testing", but then
there's no automated reminder yet to do it on the next day. Perhaps I
should implement that.

Christoph

---

From: Gwen Shapira <[email-masked]>
Date: Tue, 5 Nov 2024 16:30:50 +0000

I see it bumped now! Thank you!

Gwen