Subject: postgresql-11-citus (12, 13)

From: Wim Bertels <[email-masked]>
Date: Tue, 15 Dec 2020 11:03:40 +0100

Hello,

concerning: postgresql-11-citus

i guess this is no longer maintained or continued as a package for the
current version 12, 13?

nonetheless, thank you for all the work done, much appreciated
apt.postgresql.org

-- 
mvg,
Wim 
--
https://coronalert.be

--
A banker is a fellow who lends you his umbrella when the sun is shining
and wants it back the minute it begins to rain.
		-- Mark Twain

---

From: Hanefi Onaldi <[email-masked]>
Date: Tue, 15 Dec 2020 11:07:24 +0000

Hi Wim,

The latest citus package on PGDG repos are for 8.0.0 version that was released on 2018.

Citus creates and maintains its packages in a seperate repository. You can use the instructions at Citus website to install that repository at https://citusdata.com/download

For a sense of completeness, here are the steps to install latest Citus 9.5 running on PG13 on Debian based distros:

curl https://install.citusdata.com/community/deb.sh | sudo bash
sudo apt-get -y install postgresql-13-citus-9.5

Best,
-Hanefi

From: Wim Bertels <[email-masked]>
Date: Tuesday, 15 December 2020 13:04
To: [email-masked] <[email-masked]>
Cc: Dimitri Fontaine <[email-masked]>
Subject: [EXTERNAL] postgresql-11-citus (12, 13)
Hello,

--
mvg,
Wim
--
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcoronalert.be%2F&amp;data=04%7C01%7Chanefi.onaldi%40microsoft.com%7C1a2f6d2fdf9c4dfa686208d8a0e0ba08%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637436234618927110%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=GMQVb%2BOsUt%2FiXlXkCggkZNgT%2FnDbZ1SdeJdbP1hI5pA%3D&amp;reserved=0

---

From: Wim Bertels <[email-masked]>
Date: Tue, 15 Dec 2020 14:19:12 +0100

Hello Hanefi,

i saw this,
when i look at the script, 
this adds a separate repository

as a sysadmin i try to avoid having many repository sources, 
as this makes dist-upgrades and maintenance often harder

thank you for the feedback

kind regards,
Wim

Hanefi Onaldi schreef op di 15-12-2020 om 11:07 [+0000]:
> Citus creates and maintains its packages in a seperate repository.
> You can use the instructions at Citus website to install that
> repository at https://citusdata.com/download
>  
> For a sense of completeness, here are the steps to install latest
> Citus 9.5 running on PG13 on Debian based distros:
>  

--
https://coronalert.be

--
Civilization is the limitless multiplication of unnecessary necessities.
		-- Mark Twain

---

From: Hanefi Onaldi <[email-masked]>
Date: Tue, 15 Dec 2020 13:40:26 +0000

Hi Wim,

I am one of the maintainers of the Citus packaging repositories. Feel free to ask away if you have any issues.

Currently Citus Community repository contains only packages for the postgresql extensions we develop and maintain as a team. Namely citus, pg_auto_failover, topn, hll, pg_cron. The naming of the packages are different than those in PGDG to avoid any conflicts, and Citus repository is the place to find the most up to date packages.

Best,
Hanefi

From: Wim Bertels <[email-masked]>
Date: Tuesday, 15 December 2020 16:19
To: Hanefi Onaldi <[email-masked]>, [email-masked] <[email-masked]>
Cc: Dimitri Fontaine <[email-masked]>
Subject: Re: [EXTERNAL] postgresql-11-citus (12, 13)
Hello Hanefi,

i saw this,

kind regards,
Wim

Hanefi Onaldi schreef op di 15-12-2020 om 11:07 [+0000]:
> repository at https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcitusdata.com%2Fdownload&amp;data=04%7C01%7CHanefi.Onaldi%40microsoft.com%7C755a4cf9ff94425703a508d8a0fc0b8a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637436351683216762%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=IEzDZ8LqeYe30VA62ilSp0HGEB8u3V6RpJDwX1Pv6Uo%3D&amp;reserved=0
>
> curl https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Finstall.citusdata.com%2Fcommunity%2Fdeb.sh&amp;data=04%7C01%7CHanefi.Onaldi%40microsoft.com%7C755a4cf9ff94425703a508d8a0fc0b8a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637436351683216762%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=65ZdjQU%2Bk%2FzLnx6842UTJYL0SPux4IOR3YEEtk6d8RQ%3D&amp;reserved=0 | sudo bash

--
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcoronalert.be%2F&amp;data=04%7C01%7CHanefi.Onaldi%40microsoft.com%7C755a4cf9ff94425703a508d8a0fc0b8a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637436351683216762%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=4UBA4OhATWLT2XRvYc8R9W33T18SmmwuK4Cla0lnxrM%3D&amp;reserved=0

---

From: Christoph Berg <[email-masked]>
Date: Thu, 17 Dec 2020 17:25:14 +0100

Re: Wim Bertels
> i guess this is no longer maintained or continued as a package for the

Yes, Microsoft/Citusdata chose to maintain the package in their own
repo instead.

> nonetheless, thank you for all the work done, much appreciated

Welcome!

Christoph