Subject: Latest packages for Xenial

From: Justin Downing <[email-masked]>
Date: Thu, 12 Aug 2021 14:11:19 -0700

Hello!

I note on the Ubuntu install page (
https://www.postgresql.org/download/linux/ubuntu/) that:

The PostgreSQL Apt Repository supports the current LTS versions of Ubuntu:

20.04
18.04
16.04

But the most recent release (
https://www.postgresql.org/about/news/postgresql-134-128-1113-1018-9623-and-14-beta-3-released-2277/)
did not get packages built for 16.04 xenial.

Is the information out-of-date or was there on oversight with the latest
builds?

Thanks!

---

From: Christoph Berg <[email-masked]>
Date: Fri, 13 Aug 2021 11:11:01 +0200

Re: Justin Downing
> Is the information out-of-date or was there on oversight with the latest

Hi,

the web page is out of date, xenial is EOL from the Ubuntu side as
well.

The correct list would be (Debian is also outdated):

Debian 9 (stretch), 10 (buster), 11 (bullseye), and unstable (sid)
Ubuntu 18.04 (bionic), 20.04 (focal), 21.04 (hirsute, amd64 only), 21.10 (impish, amd64 only)

Christoph

---

From: Hanefi Onaldi <[email-masked]>
Date: Fri, 13 Aug 2021 10:05:07 +0000

Hi Justin,

Ubuntu 16.04 End-of-life date was April 30, 2021.

Maybe that can be the reason why new packages are not created for said distro.

Best,
Hanefi

________________________________
From: Justin Downing <[email-masked]>
Sent: Friday, August 13, 2021 12:11:19 AM
To: [email-masked] <[email-masked]>
Subject: [EXTERNAL] Latest packages for Xenial

You don't often get email from [email-masked]. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>
Hello!

I note on the Ubuntu install page (https://www.postgresql.org/download/linux/ubuntu/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.postgresql.org%2Fdownload%2Flinux%2Fubuntu%2F&data=04%7C01%7Chanefi.onaldi%40microsoft.com%7C67680b5c83694f17727508d95e31a3ab%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637644390027262340%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=KGZLghYM5hFaQCs0i%2BD6N6n6h0F%2BhbKIJjBVUTy1nwc%3D&reserved=0>) that:

20.04
18.04
16.04

But the most recent release (https://www.postgresql.org/about/news/postgresql-134-128-1113-1018-9623-and-14-beta-3-released-2277/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.postgresql.org%2Fabout%2Fnews%2Fpostgresql-134-128-1113-1018-9623-and-14-beta-3-released-2277%2F&data=04%7C01%7Chanefi.onaldi%40microsoft.com%7C67680b5c83694f17727508d95e31a3ab%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637644390027272297%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=1VGJKMmaijR0nV%2BH%2BQm9o2UGlvuMWCyb58bYIltYgoE%3D&reserved=0>) did not get packages built for 16.04 xenial.

Is the information out-of-date or was there on oversight with the latest builds?

Thanks!

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 13 Aug 2021 07:17:02 -0700

> Ubuntu 18.04 (bionic), 20.04 (focal), 21.04 (hirsute, amd64 only), 21.10 (impish, amd64 only)

The Postgres Ubuntu packages only officially support LTS releases.

-- 
Adrian Klaver
[email-masked]

---

From: Christoph Berg <[email-masked]>
Date: Fri, 13 Aug 2021 18:19:39 +0200

Re: Adrian Klaver
> The Postgres Ubuntu packages only officially support LTS releases.

That part is also obsolete.

Christoph

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 16 Aug 2021 11:35:48 +0200

> That part is also obsolete.

Can you provide an update to what it should actually be? Either as a
patch, or just as an explicit text of what it should be and I'll be
happy to turn that into a patch.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/
 Work: https://www.redpill-linpro.com/

---

From: Christoph Berg <[email-masked]>
Date: Mon, 16 Aug 2021 12:07:12 +0200

Re: Magnus Hagander
> happy to turn that into a patch.

Just scratch the LTS part:

The PostgreSQL Apt Repository supports the current versions of Ubuntu:

  * impish (21.10)
  * hirsute (21.04)
  * focal (20.04)
  * bionic (18.04)

on the following architectures:

    amd64
    arm64 (18.04 and newer; LTS releases only)
    i386 (18.04 and older)
    ppc64el (LTS releases only)

Christoph

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 16 Aug 2021 12:20:19 +0200

>     ppc64el (LTS releases only)

Check. And remove the sentence:
"While not fully supported, the packages often work on other non-LTS
versions as well,
by using the closest LTS version available.
"

completely?

---

From: Christoph Berg <[email-masked]>
Date: Mon, 16 Aug 2021 13:28:38 +0200

Re: Magnus Hagander
> by using the closest LTS version available.

Yes.

Christoph

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 16 Aug 2021 14:18:49 +0200

> > by using the closest LTS version available.

Done. LMK if there is anything else that needs changing.