Subject: Missing package postgresql-14-pgtap

From: Herwin Weststrate <[email-masked]>
Date: Mon, 4 Oct 2021 07:57:47 +0000

Hello,

After attempting to upgrade to Postgres 14, I noticed the package postgresql-14-pgtap is missing from the Debian repository.

Kind regards,

Herwin Weststrate

---

From: Christoph Berg <[email-masked]>
Date: Mon, 4 Oct 2021 16:02:21 +0200

Re: Herwin Weststrate
> After attempting to upgrade to Postgres 14, I noticed the package postgresql-14-pgtap is missing from the Debian repository.

Hi,

that's because pgtap hasn't released a version compatible with PG 14
yet:

https://pgdgbuild.dus.dg-i.net/view/Binaries-Beta/job/pgtap-binaries-beta/14/architecture=amd64,distribution=sid/console

22:15:25 --- /<<PKGBUILDDIR>>/test/expected/hastap.out	2019-11-25 19:03:44.000000000 +0000
22:15:25 +++ /<<PKGBUILDDIR>>/results/hastap.out	2021-08-12 20:15:19.388123291 +0000
22:15:25 @@ -500,22 +500,40 @@
22:15:25  ok 498 - has_operator( left, name, right ) fail should fail
22:15:25  ok 499 - has_operator( left, name, right ) fail should have the proper description
22:15:25  ok 500 - has_operator( left, name, right ) fail should have the proper diagnostics
22:15:25 -ok 501 - has_leftop( schema, name, right, result, desc ) should pass
22:15:25 +not ok 501 - has_leftop( schema, name, right, result, desc ) should pass
22:15:25 +# Failed test 501: "has_leftop( schema, name, right, result, desc ) should pass"
22:15:25 +#         have: false
22:15:25 +#         want: true
...

https://github.com/theory/pgtap/issues/276

Christoph

---

From: Christoph Berg <[email-masked]>
Date: Mon, 4 Oct 2021 17:26:31 +0200

Re: To Herwin Weststrate
> that's because pgtap hasn't released a version compatible with PG 14

Fwiw I built the pgtap packages now anyway, the module seems to work
even with these problems; I tested with pg-partman and mimeo.

Christoph