Subject: Pgpool-II latest package?

From: Tatsuo Ishii <[email-masked]>
Date: Tue, 05 Oct 2021 09:51:26 +0900 (JST)

Hi,

I am looking into the https://apt.postgresql.org/pub/repos/apt/dists/focal-pgdg/main/binary-amd64/Packages.
I found that the latest version of pgpool2 package is 4.1.4.
Is there any plan to release the latest version of Pgpool-II (4.1.8 or 4.2.x) for Ubuntu 20?

If you have problems with creating pgpool2 package, is there anything
I can help?  I am one of Pgpool-II developers.
--
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese:http://www.sraoss.co.jp

---

From: Christoph Berg <[email-masked]>
Date: Tue, 5 Oct 2021 17:24:22 +0200

Re: Tatsuo Ishii
> I can help?  I am one of Pgpool-II developers.

Hi Tatsuo-san,

we are looking for help maintaining the package since no one in the
team is using pgpool themselves:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=772047

Especially interesting would be getting the testsuite to run at
package build time; currently it's disabled since upstream cdb49d3.
(I never checked back to see if that problem has been resolved since
then.)

The packaging repo is there: https://salsa.debian.org/postgresql/pgpool2

We can get you on the postgresql team there if you are interested in
working on the package.

Christoph

---

From: Tatsuo Ishii <[email-masked]>
Date: Wed, 06 Oct 2021 08:56:01 +0900 (JST)

Hi Christoph,

> The packaging repo is there: https://salsa.debian.org/postgresql/pgpool2

Ok. let me see.

> We can get you on the postgresql team there if you are interested in

Yes, I am interested but I am not familiar with Ubuntu package
creation process. Is there any tutorial for the work?

BTW, I have a problem with compiling Pgpool-II docs on Ubuntu 20 (18
is fine.): jade segfaults. I can compile docs on Ubuntu 18 then copy
into Ubuntu 18, but this is really annoying. It would be nice if I can
help on this.
--
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese:http://www.sraoss.co.jp

---

From: Tatsuo Ishii <[email-masked]>
Date: Wed, 06 Oct 2021 11:07:53 +0900 (JST)

>> The packaging repo is there: https://salsa.debian.org/postgresql/pgpool2

I git cloned the repo and ran src/test/regression/regress.sh on my
Ubuntu 20 laptop. It took about 40 minutes.

I believe you already know but to run the test, you need PostgreSQL
server and client software (psql, pgbench, pg_ctl etc.), and some
extra tools like ssh, memcached, OpenSSL, JDBC driver, Perl and Ruby.
$ ./configure --with-openssl --with-memcached=/usr
$ cd src/sql
$ make install (in my case PostgreSQL is installed under /usr/local/pgsql/ with my account).
$ cd ../..
$ cd src/test/regression
$ ./regress.sh 
creating pgpool-II temporary installation ...
moving pgpool_setup to temporary installation path ...
moving watchdog_setup to temporary installation path ...
using pgpool-II at /home/t-ishii/work/Pgpool-II/current/Salsa.debian.org/pgpool2/src/test/regression/temp/installed
*************************
REGRESSION MODE          : install
PGPOOL-II                : /home/t-ishii/work/Pgpool-II/current/Salsa.debian.org/pgpool2/src/test/regression/temp/installed
PostgreSQL bin           : /usr/local/pgsql/bin
PostgreSQL Major version : 13
pgbench                  : /usr/local/pgsql/bin/pgbench
PostgreSQL jdbc          : /usr/local/pgsql/share/postgresql-9.2-1003.jdbc4.jar
*************************
testing 001.load_balance...ok.
testing 002.native_replication...ok.
testing 003.failover...ok.
testing 004.watchdog...ok.
testing 005.jdbc...ok.
testing 006.memqcache...ok.
testing 007.memqcache-memcached...ok.
testing 008.dbredirect...ok.
testing 009.sql_comments...ok.
testing 010.rewrite_timestamp...ok.
testing 011.watchdog_quorum_failover...ok.
testing 012.watchdog_failover_when_quorum_exists...ok.
testing 013.watchdog_failover_require_consensus...ok.
testing 014.watchdog_test_quorum_bypass...ok.
testing 015.watchdog_master_and_backend_fail...ok.
testing 016.node_0_is_not_primary...ok.
testing 017.node_0_is_down...ok.
testing 018.detach_primary...ok.
testing 019.log_client_messages...ok.
testing 020.allow_clear_text_frontend_auth...ok.
testing 021.pool_passwd_auth...ok.
testing 022.pool_passwd_alternative_auth...ok.
testing 023.ssl_connection...ok.
testing 024.cert_auth...ok.
testing 025.enable_shared_relcache...ok.
testing 026.temp_table...ok.
testing 027.auto_failback...ok.
testing 028.watchdog_enable_consensus_with_half_votes...ok.
testing 031.connection_life_time...ok.
testing 050.bug58...ok.
testing 051.bug60...ok.
testing 052.do_query...ok.
testing 053.insert_lock_hangs...ok.
testing 054.postgres_fdw...ok.
testing 055.backend_all_down...ok.
testing 056.bug63...ok.
testing 057.bug61...ok.
testing 058.bug68...ok.
testing 059.bug92...ok.
testing 060.memory_leak...ok.
testing 061.cancel_query...ok.
testing 062.select_error_hangs...ok.
testing 063.tables_with_space...ok.
testing 064.bug153...ok.
testing 065.bug152...ok.
testing 066.bug230...ok.
testing 067.bug231...ok.
testing 068.memqcache_bug...ok.
testing 069.memory_leak_extended...ok.
testing 070.memory_leak_extended_memqcache...ok.
testing 071.execute_and_deallocate...ok.
testing 072.meqcache_bug2...ok.
testing 073.pg_terminate_backend...ok.
out of 53 ok:53 failed:0 timeout:0
--
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese:http://www.sraoss.co.jp

---

From: Christoph Berg <[email-masked]>
Date: Wed, 6 Oct 2021 14:04:49 +0200

Re: Tatsuo Ishii
> Ok. let me see.

Thanks!

> creation process. Is there any tutorial for the work?

The basic starting point is https://www.debian.org/doc/manuals/maint-guide/ .

Packages building PG modules are a bit more involved since they have
to target several major versions at once, see pg_buildext(1) (in
postgresql-common) for more details.

> into Ubuntu 18, but this is really annoying. It would be nice if I can

That's known and unfortunately unfixed in Ubuntu. Fixed packages are
available via apt.postgresql.org:

openjade | 1.4devel1-21.3ubuntu1.pgdg20.04+1 |         groovy-pgdg | amd64, source
openjade | 1.4devel1-21.3ubuntu1.pgdg20.04+1 | groovy-pgdg-testing | amd64, source
openjade | 1.4devel1-21.3ubuntu1.pgdg20.04+1 |          focal-pgdg | amd64, ppc64el, source
openjade | 1.4devel1-21.3ubuntu1.pgdg20.04+1 |  focal-pgdg-testing | amd64, ppc64el, source

Re: Tatsuo Ishii
> extra tools like ssh, memcached, OpenSSL, JDBC driver, Perl and Ruby.

That would have to be coded into Build-Depends (for build-time
testing) and/or Depends in debian/tests/control for install-time
tests.

Christoph

---

From: Tatsuo Ishii <[email-masked]>
Date: Wed, 06 Oct 2021 23:23:16 +0900 (JST)

> The basic starting point is https://www.debian.org/doc/manuals/maint-guide/ .

Thanks. I will look into this.

> openjade | 1.4devel1-21.3ubuntu1.pgdg20.04+1 |          focal-pgdg | amd64, ppc64el, source

did not solve the problem.

> testing) and/or Depends in debian/tests/control for install-time

To be honest I don't understand for now:-) I will visit again once I
study https://www.debian.org/doc/manuals/maint-guide/ .
--
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese:http://www.sraoss.co.jp

---

From: Tatsuo Ishii <[email-masked]>
Date: Fri, 08 Oct 2021 09:42:48 +0900 (JST)

> did not solve the problem.

Strangely enough, it *sometimes" works. I haven't found the pattern in
which case openjade works or does not work. Anyway here is the
backtrace from the core file.

gdb) bt
#0  __memmove_avx_unaligned_erms ()
    at ../sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S:384
#1  0x00007fccf221f919 in ?? () from /lib/libostyle.so.1
#2  0x000055b874c0d5d8 in ?? ()
#3  0x00007fccf222150d in OpenJade_DSSSL::ProcessingMode::addRootRule(OpenSP::Owner<OpenJade_DSSSL::Expression>&, OpenJade_DSSSL::ProcessingMode::RuleType, OpenSP::Location const&, OpenJade_DSSSL::Interpreter&) () from /lib/libostyle.so.1
#4  0x00007fccf22288af in OpenJade_DSSSL::SchemeParser::doRoot() ()
   from /lib/libostyle.so.1
#5  0x00007fccf2230150 in OpenJade_DSSSL::SchemeParser::parse() ()
   from /lib/libostyle.so.1
#6  0x00007fccf2235dbf in OpenJade_DSSSL::StyleEngine::parseSpec(OpenSP::SgmlParser&, OpenSP::CharsetInfo const&, OpenSP::String<unsigned int> const&, OpenSP::Messenger&, OpenSP::Vector<OpenSP::String<unsigned int> > const&) ()
   from /lib/libostyle.so.1
#7  0x00007fccf21b70b0 in OpenJade_DSSSL::DssslApp::processSysid(OpenSP::String<unsigned int> const&) () from /lib/libostyle.so.1
#8  0x00007fccf1e93727 in OpenSP::EntityApp::processArguments(int, char**) ()
   from /lib/libosp.so.5
#9  0x00007fccf1e83f62 in OpenSP::CmdLineApp::run(int, char**) ()
   from /lib/libosp.so.5
#10 0x000055b87248d9ee in ?? ()
#11 0x00007fccf19c60b3 in __libc_start_main (main=0x55b87248d995, argc=16, 
    argv=0x7fff0a19cad8, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7fff0a19cac8)
    at ../csu/libc-start.c:308
#12 0x000055b87248ce2e in ?? ()
--
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese:http://www.sraoss.co.jp

---

From: Tatsuo Ishii <[email-masked]>
Date: Thu, 10 Feb 2022 10:52:31 +0900 (JST)

> testing) and/or Depends in debian/tests/control for install-time

Since the commit:
https://git.postgresql.org/gitweb/?p=pgpool2.git;a=commit;h=592140541bc1e0f030c2583fa85b188d3dc026a0

It is possible to run regression test against pre-installed (via
package) Pgpol-II. IMO this may solve the issue (at least partly)
regarding building and releasing packages of Pgpool-II, since lacking
tests against Pgpool-II packages is the main showstopper.

Best reagards,

---

From: Christoph Berg <[email-masked]>
Date: Fri, 11 Feb 2022 10:16:12 +0100

Re: Tatsuo Ishii

Hi Tatsuo-san,

thanks.

We can test that once it made it into a release.

Christoph

---

From: Tatsuo Ishii <[email-masked]>
Date: Sun, 13 Feb 2022 15:31:18 +0900 (JST)

> We can test that once it made it into a release.

Next week Pgpool-II new releases will be out. They will include the
commit.

Best reagards,