Subject: Unresolvable package postgresql-common-dev in latest pg12 package

From: James Guthrie <[email-masked]>
Date: Tue, 28 Jan 2025 12:58:03 +0100

Hi,

I'm trying to install the build-deps for postgresql-12 with the following, using the pgdg packages at apt.postgresql.org:

mk-build-deps postgresql-12
apt install -y ./postgresql-12-build-deps*.deb

And I'm getting the following error:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'postgresql-12-build-deps' instead of './postgresql-12-build-deps_12.22-2.pgdg22.04+1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 postgresql-12-build-deps : Depends: postgresql-common-dev but it is not installable

Apparently the 12.22 version has a Build-Depends on 'postgresql-common-dev', which is not available in the package repository. Previous versions specified 'postgresql-common'.

Is this an oversight, or am I doing something wrong?

Kind regards,
James Guthrie

---

From: Christoph Berg <[email-masked]>
Date: Tue, 28 Jan 2025 13:19:23 +0100

Re: James Guthrie

Hi,

that package will appear with the next postgresql-common release. It's
already in the *-pgdg-testing suites, but I haven't promoted
postgresql-common yet because I want to test the changes more.

Using it in the postgresql-12 B-D was done intentionally (the newer
ones will get it as well on the next round of minor releases), but
then I lost track of that dependency when promoting postgresql-12.

Sorry, it will stay in that broken state until the next PG minor
releases happen in the 2nd week of February.

I get daily reminders about this from the failing builddebcheck job:
https://jengus.postgresql.org/view/Testsuite/job/builddebcheck/
... so some of the pain can be felt here as well ;)

Christoph