Subject: Change in behavior when installing an additional PostgreSQL major version

From: Schmid Andreas <[email-masked]>
Date: Mon, 24 Feb 2025 14:51:07 +0000

Hi

I've noticed that the commit https://salsa.debian.org/postgresql/postgresql-common/-/commit/d9139f7777a42a39b5b6fabbffc9f020fad4dce5 has introduced a change in behavior when installing an additional PostgreSQL major version alongside any other already installed major version. (I originally asked on pgsql-general: https://www.postgresql.org/message-id/a17b7bcaf49848e5a1ec722ddfb3ba6e%40bd.so.ch)

So far, my PostgreSQL installation script relied on a new cluster being created in any case. Now, I had to add a separate pg_createcluster command, which basically wasn't a big deal. However, as I had to do quite some research to understand why all of a sudden my script didn't work anymore, maybe you can give some background about the reasons that led to this change?

Thanks a lot,
Andy

---

From: Christoph Berg <[email-masked]>
Date: Mon, 24 Feb 2025 16:19:39 +0100

Re: Schmid Andreas
> Now, I had to add a separate pg_createcluster command, which basically wasn't a big deal. However, as I had to do quite some research to understand why all of a sudden my script didn't work anymore, maybe you can give some background about the reasons that led to this change?

Hi,

the old behavior wasn't practical for the majority of users. To
upgrade, you had to install the new PG package and then run
"pg_dropcluster" as the first command. That was weird and possibly
dangerous.

Christoph