Subject: pgmodeler for Ubuntu 22.04

From: Dale Deibert <[email-masked]>
Date: Mon, 27 Nov 2023 13:20:02 -0700

Hi,

The latest version of pgmodeler in
https://www.postgresql.org/list/pgsql-pkg-debian/
is 1.0.1-1.pgdg22.04+1
which does not work with Ubuntu 22.04 (details here:
https://github.com/pgmodeler/pgmodeler/issues/1821).

There are newer versions of pgmodeler available that fix the problem.

Is there any way to get a newer version incorporated into the debian
repository?

Thanks,
Dale Deibert

---

From: Bradford Boyle <[email-masked]>
Date: Mon, 27 Nov 2023 20:09:15 -0800

On Mon, Nov 27, 2023 at 1:42 PM Dale Deibert <[email-masked]> wrote:
> which does not work with Ubuntu 22.04 (details here:  https://github.com/pgmodeler/pgmodeler/issues/1821).
>
> Is there any way to get a newer version incorporated into the debian repository?

It looks like newer versions of pgmodeler are excluded from jammy [1]
because qt6-svg-dev is missing from jammy's repos. As noted in [2],
pgmodeler 1.0.2+ requires Qt 6.

-- Bradford

[1]: https://git.postgresql.org/gitweb/?p=pgapt.git;a=blob;f=jenkins/pgapt-jobs.yaml;h=ab7ddd8297cc15b7f2d9753c3165ecc81cd97632;hb=HEAD#l1521
[2]: https://github.com/pgmodeler/pgmodeler/issues/1765#issuecomment-1495688195

---

From: Dale Deibert <[email-masked]>
Date: Tue, 28 Nov 2023 07:50:40 -0700

Thanks Bradford,

I understand that there is a dependency, but I am clearly missing some
context.  What is it that prevents adding qt6-svg-dev as a dependency for
pgmodeler?

Dale

On Mon, Nov 27, 2023 at 9:09 PM Bradford Boyle <[email-masked]>
wrote:

> [1]:
> https://git.postgresql.org/gitweb/?p=pgapt.git;a=blob;f=jenkins/pgapt-jobs.yaml;h=ab7ddd8297cc15b7f2d9753c3165ecc81cd97632;hb=HEAD#l1521
> [2]:
> https://github.com/pgmodeler/pgmodeler/issues/1765#issuecomment-1495688195
>

---

From: Bradford Boyle <[email-masked]>
Date: Tue, 28 Nov 2023 10:30:35 -0800

On Tue, Nov 28, 2023 at 6:50 AM Dale Deibert <[email-masked]> wrote:
> I understand that there is a dependency, but I am clearly missing some context.  What is it that prevents adding qt6-svg-dev as a dependency for pgmodeler?
qt6-svg-dev is a dependency of pgmodeler but qt6-svg-dev is not
available in jammy's repos. Running 'apt install qt6-svg-dev' results in
the error 'E: Unable to locate package qt6-svg-dev'. Looking at the
files provided by qt6-svg-dev, I suspect that the package
'libqt6svg6-dev' (which is in jammy) was renamed to 'qt6-svg-dev'. It
might be possible to build a newer version of pgmodeler for jammy using
this dependency but I believe that all packages in pgdg are (re-)built
from the same Debian source package. We would need to replace
'qt6-svg-dev' with 'libqt6svg6-dev' when building for jammy. Looking at
the generate-pgdg-source script [1], it _might_ be possible to add that
as a tweak. I can try and work on a patch for this in the next couple of
days.

--Bradford

[1]: https://git.postgresql.org/gitweb/?p=pgapt.git;a=blob;f=jenkins/generate-pgdg-source;h=75b2def605311daa3ed60e09d8cf981b3c6cdfcb;hb=HEAD

---

From: Dale Deibert <[email-masked]>
Date: Tue, 28 Nov 2023 12:59:12 -0700

Hey Bradford,

Thanks for the explanation.  It would be awesome if you could get the
package built.  All of your effort is greatly appreciated.

Dale

On Tue, Nov 28, 2023 at 11:30 AM Bradford Boyle <[email-masked]>
wrote:

> https://git.postgresql.org/gitweb/?p=pgapt.git;a=blob;f=jenkins/generate-pgdg-source;h=75b2def605311daa3ed60e09d8cf981b3c6cdfcb;hb=HEAD
>

---

From: Christoph Berg <[email-masked]>
Date: Tue, 28 Nov 2023 22:55:45 +0100

Re: Bradford Boyle
> 'libqt6svg6-dev' (which is in jammy) was renamed to 'qt6-svg-dev'.

Thanks for tracking that down, I didn't look closer in Jammy. The
package names on unstable were different enough from qt5...

> It

Actually "qt6-svg-dev | libqt6svg6-dev" is easier, the
generate-pgdg-source script is only needed for weirder changes.

Pushed, build is running.

Thanks,
Christoph