Subject: Missing dependencies on ubuntu 24.04 for libpq-dev and postgresql-server-dev-17

From: Hanefi Onaldi <[email-masked]>
Date: Mon, 23 Jun 2025 10:38:32 +0000

Hi,

I wanted to create a development environment on Ubuntu 22.04 using several packages from pgdg repositories. I want to share the error messages with you here in the hopes that this is correct venue.

Postgresql-server-dev-17 depends on libpq-dev and libpq-dev has two broken dependencies:
- libldap only has versions 2.6.X on Ubuntu 24.04 and is not compatible with libldap-2.4-2 dependency requirement.
- libssl1.1 is not available on Ubuntu 24.04. A quick search shows that it is not available in any Ubuntu version, and Debian 11 is the only Debian version that has that package available in official packaging repositories.

sh$ sudo apt install libpq-dev=17.5-1.pgdg110+1
...
The following packages have unmet dependencies:
 libpq5 : Depends: libldap-2.4-2 (>= 2.4.7) but it is not installable
          Depends: libssl1.1 (>= 1.1.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

Thanks for the help,
Hanefi

---

From: Christoph Berg <[email-masked]>
Date: Mon, 23 Jun 2025 12:50:23 +0200

Re: Hanefi Onaldi

> sh$ sudo apt install libpq-dev=17.5-1.pgdg110+1

You can't install packages for bullseye (pgdg110) on Ubuntu 22.04
(jammy). Please use the correct repository.

Christoph

---

From: Hanefi Onaldi <[email-masked]>
Date: Mon, 23 Jun 2025 12:24:02 +0000

Thanks Christoph,

You are right. It was my mistake.

I updated my repo installation scripts with the latest steps from documentation, and I can install everything now.

For reference: https://www.postgresql.org/download/linux/ubuntu/

Best,
Hanefi
________________________________
From: Christoph Berg <[email-masked]>
Sent: Monday, June 23, 2025 1:50 PM
To: Hanefi Onaldi <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [EXTERNAL] Re: Missing dependencies on ubuntu 24.04 for libpq-dev and postgresql-server-dev-17

Re: Hanefi Onaldi

Christoph