Subject: Missing version 3.5.3 of package "postgis" in PGDG apt repository for Debian Bullseye

From: Schmid Andreas <[email-masked]>
Date: Fri, 18 Jul 2025 07:49:17 +0000

Hi

In the PGDG Debian repository, the package "postgis" is available at version 3.5.3 for Debian Bookworm. However, it's available just at version 3.5.2 for Debian Bullseye. Is this by mistake, or is it expected like that?

Thank you,
Andy

---

From: Bradford Boyle <[email-masked]>
Date: Fri, 18 Jul 2025 21:53:58 -0700

Hi Andy,

Building of the postgis package was disabled for bullseye back in May.

-- Bradford

[0]: https://salsa.debian.org/postgresql/apt.postgresql.org/-/commit/c12cb5e5b2662172317363159fb5731da2c98957

---

From: Christoph Berg <[email-masked]>
Date: Sat, 19 Jul 2025 12:45:32 +0200

Re: Bradford Boyle

> ERROR:  index returned tuples in wrong order

I tried to raise that issue upstream, but did no get any reply. Not
shipping new updates with that regression seemed like the safer choice.

Christoph

---

From: Christoph Berg <[email-masked]>
Date: Mon, 21 Jul 2025 15:16:03 +0200

Re: To Bradford Boyle
> shipping new updates with that regression seemed like the safer choice.

Turns out there was a reply, but I had not enabled email notifications
in that trac instance yet:

https://trac.osgeo.org/postgis/ticket/5903

Christoph