Subject: updated extensions for postgres 18

From: Sebastian Webber <[email-masked]>
Date: Thu, 25 Sep 2025 19:50:56 -0300

Hey everyone, this is my first email to this list, so feel free to point me
out to the proper place.

Some packages are missing for postgres 18:
* pg_qualstats: https://github.com/powa-team/pg_qualstats/releases/tag/2.1.2
* pglogical: https://github.com/2ndQuadrant/pglogical/releases/tag/REL2_4_6
* pgaudit: https://github.com/pgaudit/pgaudit/releases/tag/18.0
* postgres-hll:
https://github.com/citusdata/postgresql-hll/releases/tag/v2.18
* pldebuger: https://github.com/EnterpriseDB/pldebugger/releases/tag/v1.9

Where can I patch the build files to add the new versions?

-- 
Sebastian Webber

---

From: Bradford Boyle <[email-masked]>
Date: Thu, 25 Sep 2025 21:41:33 -0700

Hi Sebastian,

It looks like all of these have packaging repos on salsa.debian.org:

* https://salsa.debian.org/postgresql/pg-qualstats
* https://salsa.debian.org/postgresql/pglogical
* https://salsa.debian.org/postgresql/pgaudit
* https://salsa.debian.org/postgresql/postgresql-hll
* https://salsa.debian.org/postgresql/pldebugger
* https://salsa.debian.org/postgresql/omnidb-plpgsql-debugger

-- Bradford

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 26 Sep 2025 11:17:00 +0100

Hi,

> https://github.com/citusdata/postgresql-hll/releases/tag/v2.18

hll 2.18 cannot be built against v18:

https://github.com/citusdata/postgresql-hll/issues/166

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
BlueSky: @devrim.gunduz.org , @gunduz.org

---

From: Sebastian Webber <[email-masked]>
Date: Fri, 26 Sep 2025 11:45:20 -0300

> Hi Sebastian,

hey, thanks for the reply!

> * https://salsa.debian.org/postgresql/omnidb-plpgsql-debugger

Ok, but i'm trying to use the packages in the pgdg repo, please see:

root@221f91773525:~# cat /etc/apt/sources.list.d/pgdg.list
deb http://apt.postgresql.org/pub/repos/apt/ jammy-pgdg main 18
root@221f91773525:~# apt update
Hit:1 http://apt.postgresql.org/pub/repos/apt jammy-pgdg InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports jammy InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports jammy-updates InRelease
Hit:4 http://ports.ubuntu.com/ubuntu-ports jammy-backports InRelease
Hit:5 http://ports.ubuntu.com/ubuntu-ports jammy-security InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@221f91773525:~# export FULL_VERSION=18.0* pg=18
apt install \
    postgresql-${pg}-pg-qualstats \
    postgresql-${pg}-pglogical \
    postgresql-${pg}-pgaudit \
    postgresql-${pg}-hll \
    postgresql-${pg}-pldebugger
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package postgresql-18-pglogical
E: Unable to locate package postgresql-18-hll
E: Unable to locate package postgresql-18-pldebugger

-- 
Sebastian Webber

---

From: Sebastian Webber <[email-masked]>
Date: Fri, 26 Sep 2025 11:45:58 -0300

> https://github.com/citusdata/postgresql-hll/issues/166
Thanks for pointing this out. I will open a new issue in the project.

-- 
Sebastian Webber
Chegou a ver o meu blog <http://swebber.me>?  Dá uma olhada no que eu ando
aprontando: http://swebber.me

---

From: Bradford Boyle <[email-masked]>
Date: Fri, 26 Sep 2025 18:01:41 -0700

> Ok, but i'm trying to use the packages in the pgdg repo, please see:

The packages in the pgdg repo are built from the packaging repos hosted
on salsa.debian.org. Here are the Jenkins job definitions:

https://salsa.debian.org/postgresql/apt.postgresql.org/-/blob/master/jenkins/pgapt-jobs.yaml

-- Bradford

---

From: Sebastian Webber <[email-masked]>
Date: Tue, 7 Oct 2025 23:10:22 -0300

Hey Bradford, sorry for the delay!

> * https://salsa.debian.org/postgresql/omnidb-plpgsql-debugger

i'm looking for the packages built for postgres 18, like:

   - postgresql-18-pg-qualstats
   - postgresql-18-pglogical
   - postgresql-18-pgaudit
   - postgresql-18-hll
   - postgresql-18-pldebugger

please see that the packages are available for pg 17 but not 18:

root@22b5ad83b91e:/# export pg=18
> root@22b5ad83b91e:/# export pg=17
> apt install \
> The following additional packages will be installed:
>   libbsd0 libedit2 libicu70 libllvm15 libmd0 libpq5 libsensors-config
> libsensors5 libxml2 libxslt1.1 locales postgresql-17 postgresql-client-17
> postgresql-client-common postgresql-common
>   sysstat tzdata xz-utils
> Suggested packages:
>   libpq-oauth lm-sensors pgadmin3 | pgadmin4 postgresql-doc-17 isag
> The following NEW packages will be installed:
>   libbsd0 libedit2 libicu70 libllvm15 libmd0 libpq5 libsensors-config
> libsensors5 libxml2 libxslt1.1 locales postgresql-17 postgresql-17-hll
> postgresql-17-pg-qualstats postgresql-17-pgaudit
>   postgresql-17-pglogical postgresql-17-pldebugger postgresql-client-17
> sysstat tzdata xz-utils
> The following packages will be upgraded:
>   postgresql-client-common postgresql-common
> 2 upgraded, 21 newly installed, 0 to remove and 4 not upgraded.
> Need to get 64.3 MB of archives.
> After this operation, 254 MB of additional disk space will be used.
> Do you want to continue? [Y/n]

Also noticed that some of them are missing tags, like hll that misses a tag
with the pg18 support (issue:
https://github.com/citusdata/postgresql-hll/issues/169)

any change to build these packages?

-- 
Sebastian Webber

---

From: Christoph Berg <[email-masked]>
Date: Thu, 9 Oct 2025 15:06:18 +0200

Re: Sebastian Webber
> any change to build these packages?

If the upstream support is still missing like you noted, it's going to
be hard.

For everything else, packages should be there now or appear soon.

Christoph