Subject: Debian buster - upgrade to postgresql 15.1 removes roundcube

From: Alexandre Pereira bühler<[email-masked]>
Date: Mon, 14 Nov 2022 13:34:39 -0300

The postgresql 15.1 update tries to install the dbconfig-common 2.0.22 
package which breaks the roundcube dependency.
Please look below

root@server:/etc/mysql# apt-get install postgresql-15
Reading package lists... Done
Building dependencies tree
Reading status information... Ready
The following packages were installed automatically and are no longer 
needed:
fonts-glyphicons-halflings libjs-bootstrap libjs-bootstrap4 
libjs-codemirror libjs-jquery-minicolors libjs-jquery-ui 
libjs-jstimezonedetect
libjs-popper.js node-jquery php-auth-sasl php-mail-mime 
php-masterminds-html5 php-net-sieve php-net-smtp php-net-socket
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
dbconfig-common roundcube roundcube-core roundcube-plugins
The following packages will be updated:
postgresql-15
1 packages updated, 0 new packages installed, 4 to be removed and 0 not 
updated.
You need to download 16.0 MB of files.
After this operation, 24.2 MB of disk space will be freed.
Do you want to continue? [Y/n] n

root@server:/etc/mysql# apt-get dist-upgrade
Reading package lists... Done
Building dependencies tree
Reading status information... Ready
Calculating update... Done
The following packages will be kept in their current versions:
postgresql-15
0 packages updated, 0 new packages installed, 0 to be removed and 1 not 
updated.

-- 
Alexandre Pereira Bühler
Simão &  Bühler Ltda (Infobrindes)
http://www.simaoebuhler.com.br
[email-masked]
Telefone: (41) 99831-7470

---

From: Christoph Berg <[email-masked]>
Date: Tue, 15 Nov 2022 18:03:05 +0100

Re: Alexandre Pereira bühler
> package which breaks the roundcube dependency.

Hi,

the problem is that dbconfig-common older than that version is
incompatible with PG15's stricter permissions on the built-in default
public schema.

The updated dbconfig-common version is available via backports (at
least in bullseye).

I'll see if we can include that version in our repo as well.

Christoph

---

From: Alexandre Pereira bühler<[email-masked]>
Date: Tue, 15 Nov 2022 19:11:49 -0300

Hello,
In debian backports do not have the package in the requested version 2.0.22.

---

From: Alexandre Pereira bühler<[email-masked]>
Date: Tue, 15 Nov 2022 19:16:46 -0300

Hi,
I saw that you put the requested dbconfig-common in the repository.
Thanks