Subject: Error accessing to pgdg-centos94-9.4-1.noarch.rpm

From: Juan Gallego Molero <[email-masked]>
Date: Mon, 26 Sep 2016 19:47:09 +0000 (UTC)

Hi
I try to access to pgdg-centos94-9.4-1 RPM file, but this file has been removed from yum.postgresql.org. I think that was removed last saturday or sunday.
https://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-1.noarch.rpm <== removed file

But when I go to https://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/, I can see these similar RPM:...pgdg-centos94-9.4-2.noarch.rpm 2015-Oct-21 08:52:11 5.2K application/x-redhat-package-managerpgdg-centos94-9.4-3.noarch.rpm 2016-Sep-25 10:42:18 5.3K application/x-redhat-package-manager...
I have two questions:   
   - pgdg-centos94-9.4-1.noarch.rpm has been removed accidentally?   

   - If previous questions is "not", what is yum.postgresql policy about retention period for rpm files?

Thanks a lot

---

From: Juan Gallego Molero <[email-masked]>
Date: Mon, 26 Sep 2016 20:08:26 +0000 (UTC)

Hi
Sorry, we are not interested at pgdg-centos rpm, we are more interested about postgres94-* rpm.
Actually I used  Postgresql 9.4.3, and I have not seen these rpm at yum.postgresql.org server. What is yum.postgresql policy about retention period for rpm files?

Thanks 

    El Lunes 26 de septiembre de 2016 21:47, Juan Gallego Molero <[email-masked]> escribió:

 Hi

Thanks a lot

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 26 Sep 2016 23:31:47 +0300

Hi,

On Mon, 2016-09-26 at 19:47 +0000, Juan Gallego Molero wrote:
> 
> I try to access to pgdg-centos94-9.4-1 RPM file, but this file has been
> removed from yum.postgresql.org. I think that was removed last saturday or
> sunday.

Right, we released new repo RPMs. Please always find the latest version from ht
tps://yum.postgresql.org/repopackages.php 

> But when I go to https://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/, I can
> see these similar RPM:...pgdg-centos94-9.4-2.noarch.rpm 2015-Oct-21 08:52:11
> 5.2K application/x-redhat-package-managerpgdg-centos94-9.4-3.noarch.rpm 2016-
> Sep-25 10:42:18 5.3K application/x-redhat-package-manager...
> I have two questions:   

No, it was intentional.

> retention period for rpm files?

Starting Sunday, we keep only n-2 releases to save disk space and create less
delta RPMs. Please visit the URL I gave above for the up2date repo file.

Regards,
-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 26 Sep 2016 23:34:03 +0300

Hi,

On Mon, 2016-09-26 at 20:08 +0000, Juan Gallego Molero wrote:
> Actually I used  Postgresql 9.4.3, and I have not seen these rpm at
> yum.postgresql.org server. What is yum.postgresql policy about retention
> period for rpm files?

Oh, we never kept any release that much, even during manual cleanup. Starting
Sunday, we started purging the repo automagically, with keeping only last 3
releases. 

(We don't want our users to use older and buggy and insecure PostgreSQL
releases ;) )

Regards,