Subject: Control Files Missing from postgis2_92 Installation on CentOS 5 x86_64

From: Jeff Misener <[email-masked]>
Date: Thu, 30 Jul 2015 18:55:18 -0300

Hello,

I'm trying to enable the postgis extension on an installation of postgis2_92 from pgdg-92-centos.repo, but it seems that postgis.control is missing:

[postgres@webapp01 ~]$ psql twist
psql (9.2.13)
Type "help" for help.

twist=# CREATE EXTENSION postgis;
ERROR:  could not open extension control file "/usr/pgsql-9.2/share/extension/postgis.control": No such file or directory

Here's a listing of the extension directory:

[root@webapp01 ~]# ls -l /usr/pgsql-9.2/share/extension/
total 12
-rw-r--r-- 1 root root 332 Jun 11 09:13 plpgsql--1.0.sql
-rw-r--r-- 1 root root 179 Jun 11 09:13 plpgsql.control
-rw-r--r-- 1 root root 381 Jun 11 09:13 plpgsql--unpackaged--1.0.sql

Here are the packages I have installed:

[root@webapp01 ~]# yum list postg*
[...]
Installed Packages
postgis2_92.x86_64                                                                         2.0.6-2.rhel5                                                                installed
postgis2_92-client.x86_64                                                                  2.0.6-2.rhel5                                                                installed
postgis2_92-debuginfo.x86_64                                                               2.0.6-2.rhel5                                                                installed
postgis2_92-devel.x86_64                                                                   2.0.6-2.rhel5                                                                installed
postgis2_92-docs.x86_64                                                                    2.0.6-2.rhel5                                                                installed
postgis2_92-utils.x86_64                                                                   2.0.6-2.rhel5                                                                installed
postgresql92.x86_64                                                                        9.2.13-1PGDG.rhel5                                                           installed
postgresql92-devel.x86_64                                                                  9.2.13-1PGDG.rhel5                                                           installed
postgresql92-libs.x86_64                                                                   9.2.13-1PGDG.rhel5                                                           installed
postgresql92-server.x86_64                                                                 9.2.13-1PGDG.rhel5                                                           installed
postgresqlclient81.x86_64                                                                  8.1.17-1.el5.centos                                                          installed

I have postgresqlclient81.x86_64 installed to support some existing applications. Could that be causing a problem? Any help you could provide would be much appreciated.

Thanks,
Jeff

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 26 Aug 2015 13:21:12 +0300

Hi,

The gdal version in RHEL 5 is insufficient for raster support, and
raster support is required for creating the extension. I think the only
solution is using a recent RHEL version.

Regards, Devrim

On Thu, 2015-07-30 at 18:55 -0300, Jeff Misener wrote:
> Hello,
> 
> I'm trying to enable the postgis extension on an installation of
> postgis2_92 from pgdg-92-centos.repo, but it seems that
> postgis.control is missing:
> 
> ERROR:  could not open extension control file "/usr/pgsql
> -9.2/share/extension/postgis.control": No such file or directory
> 
> postgis2_92.x86_64                                                   
>                       2.0.6-2.rhel5                                  
>                               installed
> postgis2_92-client.x86_64                                            
>                       2.0.6-2.rhel5                                  
>                               installed
> postgis2_92-debuginfo.x86_64                                         
>                       2.0.6-2.rhel5                                  
>                               installed
> postgis2_92-devel.x86_64                                             
>                       2.0.6-2.rhel5                                  
>                               installed
> postgis2_92-docs.x86_64                                              
>                       2.0.6-2.rhel5                                  
>                               installed
> postgis2_92-utils.x86_64                                             
>                       2.0.6-2.rhel5                                  
>                               installed
> postgresql92.x86_64                                                  
>                       9.2.13-1PGDG.rhel5                             
>                               installed
> postgresql92-devel.x86_64                                            
>                       9.2.13-1PGDG.rhel5                             
>                               installed
> postgresql92-libs.x86_64                                             
>                       9.2.13-1PGDG.rhel5                             
>                               installed
> postgresql92-server.x86_64                                           
>                       9.2.13-1PGDG.rhel5                             
>                               installed
> postgresqlclient81.x86_64                                            
>                       8.1.17-1.el5.centos                            
>                               installed
> 
> I have postgresqlclient81.x86_64 installed to support some existing
> applications. Could that be causing a problem? Any help you could
> provide would be much appreciated.
> 
> Thanks,
> Jeff

-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum