Subject: How to Import rpm signature

From: Mattie McKnight <[email-masked]>
Date: Wed, 7 Oct 2015 19:51:21 +0000

I need help with the following note in the documentation:
Many of the RPMs are signed with the PGP key of the package builder. Directories contain a CURRENT_MAINTAINER file which includes the name/email of the package builder and link to their PGP key. You might want to import the signature before you'll install the RPM:
rpm -import http://link/to/the/pgp/key

I did a direct download from this location:  http://yum.postgresql.org/9.3/redhat/rhel-6-x86_64/repoview/

What is the correct format for importing the key - I found this example in the documentation:
rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6

Thanks ...

-mmck-

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 07 Oct 2015 23:00:42 +0300

Hi Mattie,

> I need help with the following note in the documentation:

Can you please point me which doc is this? This is a bit outdated, we
don't have CURRENT_MAINTAINER file anymore.

Still:

> Many of the RPMs are signed with the PGP key of the package builder.
> Directories contain a CURRENT_MAINTAINER file which includes the
> name/email of the package builder and link to their PGP key. You
> might want to import the signature before you'll install the RPM:
> I did a direct download from this location:  
> http://yum.postgresql.org/9.3/redhat/rhel-6-x86_64/repoview/
> 

rpm --import http://yum.postgresql.org/RPM-GPG-KEY-PGDG-94

(We have one unique key for all releases, the version number is there
for historical reasons).

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum