Subject: EL-7 PostgreSQL 9.4

From: Justin King <[email-masked]>
Date: Wed, 4 Nov 2015 13:35:21 -0500

Greetings,

The EL7 RPM for postgresql94, postgresql94-server appears to be missing
executables in the path. Additionally repmgr94 does not get placed in the
path either. The following is a list of provided files by the EL7
postgresql packages and your postgresql packages.

*postgresql/postgresql-server*:
/usr/bin/clusterdb
/usr/bin/createdb
/usr/bin/createlang
/usr/bin/createuser
/usr/bin/dropdb
/usr/bin/droplang
/usr/bin/dropuser
/usr/bin/pg_config
/usr/bin/pg_dump
/usr/bin/pg_dumpall
/usr/bin/pg_restore
/usr/bin/psql
/usr/bin/reindexdb
/usr/bin/vacuumdb
/usr/bin/clusterdb
/usr/bin/createdb
/usr/bin/createlang
/usr/bin/createuser
/usr/bin/dropdb
/usr/bin/droplang
/usr/bin/dropuser
/usr/bin/pg_config
/usr/bin/pg_dump
/usr/bin/pg_dumpall
/usr/bin/pg_restore
/usr/bin/psql
/usr/bin/reindexdb
/usr/bin/vacuumdb
/usr/bin/initdb
/usr/bin/pg_basebackup
/usr/bin/pg_controldata
/usr/bin/pg_ctl
/usr/bin/pg_receivexlog
/usr/bin/pg_resetxlog
/usr/bin/postgres
/usr/bin/postgresql-check-db-dir
/usr/bin/postgresql-setup
/usr/bin/postmaster

*postgresql94/postgresql94-server*:
/usr/bin/psql
/usr/bin/clusterdb
/usr/bin/createdb
/usr/bin/createlang
/usr/bin/createuser
/usr/bin/dropdb
/usr/bin/droplang
/usr/bin/dropuser
/usr/bin/pg_basebackup
/usr/bin/pg_dump
/usr/bin/pg_dumpall
/usr/bin/pg_restore
/usr/bin/reindexdb
/usr/bin/vacuumdb

Lastly the .bash_profile installed by your package does not source
/etc/profile.

*postgres/postgresql-server*:
[ -f /etc/profile ] && source /etc/profile PGDATA=/var/lib/pgsql/data
export PGDATA

Are they not installed as alternatives for a reason, or just missed? :)

Justin

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 04 Nov 2015 23:15:55 +0300

Hi,
On Wed, 2015-11-04 at 13:35 -0500, Justin King wrote:

> The EL7 RPM for postgresql94, postgresql94-server appears to be 
> missing executables in the path.

It is on purpose. We only put the binaries under $PATH which are cross
-version compatible. The rest goes under their own dirs.

>  Additionally repmgr94 does not get placed in the
> path either.

Same as above.

Regards,

-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR