Subject: what sub-package shoudl we use for pg_rewind

From: Pavel Raiskup <[email-masked]>
Date: Wed, 06 Jan 2016 21:50:28 +0100

Hi Devrim,

I'm tempted to put pg_rewind tool into 'postgresql-server.rpm', but
postgresql-9.5.spec in pgrms installs this into 'postgresql.rpm'.

What is better approach?

Thanks, Pavel

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 06 Jan 2016 23:09:32 +0200

Hi Pavel,

> postgresql-9.5.spec in pgrms installs this into 'postgresql.rpm'.

Awesome question. Here are the list of binaries that we install with
each RPM:

$ rpm -ql postgresql95|grep bin
/usr/pgsql-9.5/bin/clusterdb
/usr/pgsql-9.5/bin/createdb
/usr/pgsql-9.5/bin/createlang
/usr/pgsql-9.5/bin/createuser
/usr/pgsql-9.5/bin/dropdb
/usr/pgsql-9.5/bin/droplang
/usr/pgsql-9.5/bin/dropuser
/usr/pgsql-9.5/bin/pg_archivecleanup
/usr/pgsql-9.5/bin/pg_basebackup
/usr/pgsql-9.5/bin/pg_config
/usr/pgsql-9.5/bin/pg_dump
/usr/pgsql-9.5/bin/pg_dumpall
/usr/pgsql-9.5/bin/pg_isready
/usr/pgsql-9.5/bin/pg_receivexlog
/usr/pgsql-9.5/bin/pg_restore
/usr/pgsql-9.5/bin/pg_rewind
/usr/pgsql-9.5/bin/pg_test_fsync
/usr/pgsql-9.5/bin/pg_test_timing
/usr/pgsql-9.5/bin/pg_upgrade
/usr/pgsql-9.5/bin/pg_xlogdump
/usr/pgsql-9.5/bin/pgbench
/usr/pgsql-9.5/bin/psql
/usr/pgsql-9.5/bin/reindexdb
/usr/pgsql-9.5/bin/vacuumdb

$ rpm -ql postgresql95-server|grep bin
/usr/pgsql-9.5/bin/initdb
/usr/pgsql-9.5/bin/pg_controldata
/usr/pgsql-9.5/bin/pg_ctl
/usr/pgsql-9.5/bin/pg_resetxlog
/usr/pgsql-9.5/bin/postgres
/usr/pgsql-9.5/bin/postgresql95-check-db-dir
/usr/pgsql-9.5/bin/postgresql95-setup
/usr/pgsql-9.5/bin/postmaster

I pushed it into main package, because it is not a "server" tool, and
more like a utility. It is not something like pg_ctl or initdb.

Why do you want to push it into -server subpackage?

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Pavel Raiskup <[email-masked]>
Date: Wed, 06 Jan 2016 22:17:18 +0100

On Wednesday 06 of January 2016 23:09:32 Devrim GÜNDÜZ wrote:
> [..]

It kind of sounds like tool useful for implementing slave-to-master
promotion (but both-ways).  And, given by tool's parameters, at least one
"data directory" needs to be local.

Thus I would bet it does not make sense to have this tool installed
without server package.

Pavel

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 06 Jan 2016 23:22:25 +0200

Hi,

On Wed, 2016-01-06 at 22:17 +0100, Pavel Raiskup wrote:
> promotion (but both-ways).  And, given by tool's parameters, at least
> one "data directory" needs to be local.
> 

Good point, so then we will need to move pg_basebackup,
pg_archivecleanup, pg_receivexlog, etc, to the server package, right?

I'd like to include only the core-server related tools in that
subpackage.

Jeff, what do you think?

Regards,

---

From: Pavel Raiskup <[email-masked]>
Date: Wed, 06 Jan 2016 22:50:11 +0100

> pg_archivecleanup, pg_receivexlog, etc, to the server package, right?

Ah, I missed those are in postgresql-9.5.rpm too -- so IMO yes.   Except
that in Fedora we install pg_archivecleanup into postgresql-contrib (which
reflects that it is in ./contrib/ subdirectory in upstream source, since
the dist-git commit 4753f369).

Thanks, Pavel

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 06 Jan 2016 23:59:14 +0200

Hi,

On Wed, 2016-01-06 at 22:50 +0100, Pavel Raiskup wrote:
> Ah, I missed those are in postgresql-9.5.rpm too -- so IMO yes.  
> Except that in Fedora we install pg_archivecleanup into postgresql-
> contrib (which reflects that it is in ./contrib/ subdirectory in
> upstream source, since the dist-git commit 4753f369).

Well, I'll leave RH packaging decision to you, for sure. It's been a
while since PGDG RPMs and RH packages have chosen separate ways (like
postgresql-setup stuff). and our multi version paths. I still think
what we do in PGDG RPMs are consistent at some point, but I am open to
hear ideas from other people, too.

Regards,