Subject: Pgpool-II RPM package versions

From: Nigel Thompson <[email-masked]>
Date: Wed, 28 Sep 2016 16:23:38 +0000

Hi,

We have noticed that the Postgresql 9.3 yum repo for RedHat no longer contains RPMs for pgpool-II version 3.4.x.

What is the policy on retention of older package versions?
Are the older versions archived anywhere accessible?

Regards,
Nigel Thompson

This email is only intended for the person to whom it is addressed and may contain confidential information. If you have received this email in error, please notify the sender and delete this email which must not be copied, distributed or disclosed to any other person.

Unless stated otherwise, the contents of this email are personal to the writer and do not represent the official view of Ordnance Survey. Nor can any contract be formed on Ordnance Survey's behalf via email. We reserve the right to monitor emails and attachments without prior notice.

Thank you for your cooperation.

Ordnance Survey Limited (Company Registration number 09121572)
Registered Office: Explorer House
Adanac Drive
Southampton SO16 0AS
Tel: 03456 050505
http://www.os.uk

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 28 Sep 2016 20:57:24 +0300

Hi Nigel,

On Wed, 2016-09-28 at 16:23 +0000, Nigel Thompson wrote:
> We have noticed that the Postgresql 9.3 yum repo for RedHat no longer
> contains RPMs for pgpool-II version 3.4.x.

Right, we have 3.5.X for every PostgreSQL release.

> What is the policy on retention of older package versions?

We keep n-2 releases, where n is the latest stable minor version.

> Are the older versions archived anywhere accessible?

Unfortunately no, but you can build your own RPMs pretty much easily. You can
get tarball from pgpool.net, and grab spec file from our git repo:
https://git.postgresql.org/gitweb/?p=pgrpms.git

Then, just modify the version in spec file and build the packages.

An old but almost up2date guide is here:

https://people.planetpostgresql.org/devrim/index.php?/archives/44-How-To-Build-Your-Own-PostgreSQL-and-related-software-RPMs-on-CentOSRHELFedora.html

Please let us know if you need more help.

Regards,

-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR