Subject: 403 forbidden when trying to download anything from /9.4/redhat/rhel-6-x86_64

From: Jacek Wielemborek <[email-masked]>
Date: Thu, 29 Sep 2016 14:29:53 +0200

Hi,

I just found that two of my computers (with IPs 31.183.23.99 and
73.181.241.226) cannot download anything from this directory, for example:

d33tah@gitlab:~$ curl -vv
http://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-3.noarch.rpm
* Hostname was NOT found in DNS cache
*   Trying 174.143.35.196...
* Connected to yum.postgresql.org (174.143.35.196) port 80 (#0)
> GET /9.4/redhat/rhel-6-x86_64/pgdg-centos94-9.4-3.noarch.rpm HTTP/1.1
> User-Agent: curl/7.38.0
> Host: yum.postgresql.org
> Accept: */*
>
< HTTP/1.1 403 Forbidden
< Content-Type: text/html
< Content-Length: 345
< Date: Thu, 29 Sep 2016 12:28:51 GMT
* Server lighttpd/1.4.35 is not blacklisted
< Server: lighttpd/1.4.35
<
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
         "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
 <head>
  <title>403 - Forbidden</title>
 </head>
 <body>
  <h1>403 - Forbidden</h1>
 </body>
</html>
* Connection #0 to host yum.postgresql.org left intact

Could you help me resolve the problem?

Cheers,
Jacek Wielemborek

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 29 Sep 2016 15:36:31 +0300

Hi,

As you can see from https://yum.postgresql.org/repopackages.php , the repo RPMS
are located at download.postgresql.org . 

Please change your scripts and use the actual location. We disabled direct
downloads from yum.postgresql.org.

Thanks!

Regards, Devrim

On Thu, 2016-09-29 at 14:29 +0200, Jacek Wielemborek wrote:
>          "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">;

-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Christoph Berg <[email-masked]>
Date: Thu, 29 Sep 2016 15:35:41 +0200

Re: Devrim Gündüz 2016-09-29 <[email-masked]>

Hi,

there's been 5 independent questions about this on #postgresql within
the past 30 minutes. Maybe the repopackages page could use a Big Fat
note so people will notice what changed and can update their download
scripts.

Christoph

---

From: Jacek Wielemborek <[email-masked]>
Date: Thu, 29 Sep 2016 15:47:31 +0200

> note so people will notice what changed and can update their download

Thanks. Why the change anyway? The error message could probably mention
the solution as well.

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 29 Sep 2016 18:29:32 +0300

Hi,

> note so people will notice what changed and can update their download

Well, if people installed PostgreSQL for the first time on the machines since
Oct 2015, they won't suffer this problem. For the people who haven't updated
their repo files, it is the right time to do so.

I'm working with sysadmins team, to see if we can redirect something.

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 29 Sep 2016 18:32:51 +0300

Hi,

> Thanks. Why the change anyway? The error message could probably mention

We changed this last year, and it was the time to ask people to update their
repo RPMs :(

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 29 Sep 2016 18:57:39 +0300

Hi,

> Thanks. Why the change anyway? The error message could probably mention

For the archives: sysadmins team just made a change to redirect all of those
requests to download.postgresql.org, so you should not get any more errors now.

Regards,