Subject: Source RPM's or spec files

From: David Andruczyk <[email-masked]>
Date: Wed, 18 Jan 2017 15:33:46 +0000

Where are the .src.rpm's ?  I need to repackage an older version of postGIS in order to facilitate an easier upgrade path from postgresql 9.2 to 9.6 but without the .src.rpm or a recent spec file it will be extremely difficult to build a package that is "clean".

The spec file within the postgis source tarball is extremely out of date (for version 1.2.0),  so what do you use for generating the current RPM's available on your repository?

Thanks!

David J. Andruczyk
Systems Engineer

O: 585-444-2598
E: mailto:[email-masked]

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 19 Jan 2017 00:51:06 +0300

Hi,

On Wed, 2017-01-18 at 15:33 +0000, David Andruczyk wrote:
> Where are the .src.rpm's ? 

They are here:

https://yum.postgresql.org/srpm-packages.php
https://download.postgresql.org/pub/repos/yum/srpms/

>  I need to repackage an older version of postGIS in order to facilitate an
> easier upgrade path from postgresql 9.2 to 9.6 but without the .src.rpm or a
> recent spec file it will be extremely difficult to build a package that is
> "clean".

Right.

> The spec file within the postgis source tarball is extremely out of date (for
> version 1.2.0),  so what do you use for generating the current RPM's
> available on your repository?

Spec files are here:

https://git.postgresql.org/gitweb/?p=pgrpms.git

Please let us know if you need more help.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: David Andruczyk <[email-masked]>
Date: Wed, 18 Jan 2017 22:15:02 +0000

Thanks!  That was exactly what I was looking for

________________________________
From: Devrim Gündüz <[email-masked]>
Sent: Wednesday, January 18, 2017 4:51:06 PM
To: David Andruczyk; [email-masked]
Subject: Re: [pgsql-pkg-yum] Source RPM's or spec files

Hi,

They are here:

Right.

Spec files are here:

Regards,