Subject: package python-blinker is missing in pgdg94

From: Pausch Manfred <[email-masked]>
Date: Fri, 20 Jan 2017 12:51:12 +0000

Hello guys,

thanks for maintaining the PostgreSQL YUM repository. It made my task to setup a new PostgreSQL server much easier :-)

Currently I am on Oracle Linux 7 x86_64 and wanted to install pgadmin4 from
the repository PGDG94. I'm using PostgreSQL 9.4 because newer versions are not yet supported by the application.

But when I try to install then yum install pgadmin4-v1 pgadmin4-v1-docs
says  Error: Package: pgadmin4-v1-web-1.1-4.rhel7.noarch (pgdg94)
           Requires: python-blinker >= 1.3

So python-blinker seems not to exist in the repository: https://download.postgresql.org/pub/repos/yum/9.4/redhat/rhel-7.3-x86_64/
Just for curiosity I had a look to the repos for PGSQL 9.5 and 9.6. In 9.5 it also doesn't exist but in 9.6 it exists.
https://download.postgresql.org/pub/repos/yum/9.5/redhat/rhel-7.3-x86_64/
https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-7.3-x86_64/

FYI, the repos that I configured:
[root@dete2414-vm01 yum.repos.d]# yum repolist
Loaded plugins: ulninfo
repo id                          repo name                                                                                    status
epel/x86_64                      Extra Packages for Enterprise Linux 7 - x86_64                                               11,053
ol7_MySQL56/x86_64               MySQL 5.6 for Oracle Linux 7 (x86_64)                                                           288
ol7_UEKR4/x86_64                 Latest Unbreakable Enterprise Kernel Release 4 for Oracle Linux 7Server (x86_64)                277
ol7_latest/x86_64                Oracle Linux 7Server Latest (x86_64)                                                         18,342
pgdg94/7Server/x86_64            PostgreSQL 9.4 7Server - x86_64                                                                 388
repolist: 30,348

[root@dete2414-vm01 yum.repos.d]# cat pgdg-94-oraclelinux.repo
[pgdg94]
name=PostgreSQL 9.4 $releasever - $basearch
baseurl=https://download.postgresql.org/pub/repos/yum/9.4/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-94

[pgdg94-source]
name=PostgreSQL 9.4 $releasever - $basearch - Source
failovermethod=priority
baseurl=https://download.postgresql.org/pub/repos/yum/srpms/9.4/redhat/rhel-$releasever-$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-94

Could you check this, please?

Thanks and best regards.

Manfred

--
<http://www.tgw-group.com/>

Manfred Pausch
Team Lead DBA

TGW Software Services GmbH
D-92552 Teunz, Lindenweg 13
Phone +49 9671 9216 151
[email-masked]<mailto:[email-masked]> | www.tgw-group.com<http://www.tgw-group.com>

Amtsgericht Amberg, Aktenzeichen: HRB 5501
Geschäftsführer: Peter Ehrenhuber, Ralf Klausnitzer, Harald Schröpf
_______________________________________________________________________

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 19 Feb 2017 13:31:22 +0300

Hi Manfred,
On Fri, 2017-01-20 at 12:51 +0000, Pausch Manfred wrote:

> thanks for maintaining the PostgreSQL YUM repository. It made my task to
> setup a new PostgreSQL server much easier :-)

You are welcome :-)

>            Requires: python-blinker >= 1.3

Sorry for the late response. I was waiting for 1.2 to be released, because 1.1
RPMs were broken already.

I fixed this the other day, along with 1.2 release. Can you please test again?

Regards,
-- 
Devrim Gündüz
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Pausch Manfred <[email-masked]>
Date: Wed, 22 Feb 2017 07:00:52 +0000

Hello Devrim,

thanks for your support.
Now it works as expected :-)

Best regards.

Manfred

--
Manfred Pausch
Team Lead Database Administration

TGW Software Services GmbH
D-92552 Teunz, Lindenweg 13
Phone +49 9671 9216 151
[email-masked] | www.tgw-group.com

The information transmitted, including attachments, is intended only for the person(s) or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and destroy any copies of this information.

> -----Ursprüngliche Nachricht-----
> Von: Devrim Gündüz [mailto:[email-masked]]
> Gesendet: Sonntag, 19. Februar 2017 11:31
> An: Pausch Manfred <[email-masked]>; 'pgsql-pkg-
> [email-masked]' <[email-masked]>
> Betreff: Re: [pgsql-pkg-yum] package python-blinker is missing in pgdg94
> 
> 
> Hi Manfred,
> > thanks for maintaining the PostgreSQL YUM repository. It made my task
> > to setup a new PostgreSQL server much easier :-)
> 
> You are welcome :-)
> 
> > Currently I am on Oracle Linux 7 x86_64 and wanted to install pgadmin4
> > from the repository PGDG94. I'm using PostgreSQL 9.4 because newer
> > versions are not yet supported by the application.
> >
> > But when I try to install then yum install pgadmin4-v1
> > pgadmin4-v1-docs says  Error: Package:
> > pgadmin4-v1-web-1.1-4.rhel7.noarch (pgdg94)
> EnterpriseDB: http://www.enterprisedb.com PostgreSQL Danışmanı/Consultant,
> Red Hat Certified Engineer

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum